Cannot add license


#1

When i hit the “add license” button, i get this:

I have a pro license for 2014, and have upgraded to 2015.


#2

All SketchUp licenses are version-specific. Did you get a new license for your upgrade, or are you trying to apply your 2014 license?


#3

I was eligible and got am upgraded one, but it doesnt matter.
I either get the screen shot below, or a “bummer, your offline” message.
Ive pasted the license in the “advanced” window, and got the same bummer
message, or the same as the pic below.
Im running sketchup 2015 64 bit, and me firewall is completely off.


#4

Well, that eliminates the obvious. Time to call in the Trimble guys…


#5

Wow. I’ve never seen that. The window before that, clicking on “Add License” button, was normal?


#6

delete cache/cookies of the MS Internet Explorer or go to “Help > License…”.


#7

Cleared cache and cookies, no change.


#8

Also tried setting IE to default browser, still no change.


#9

MS IE: ensure that JavaScript (not Java) is activated and the security setting for the internet zone is is set to “medium-high” max.


#10

Verified javascript is enabled and working in my IE.
Which is also verified to be the latest version in win 7 x64 .
I also tried setting the security to “low” and restarting IE. Nada.

The weird window im getting seems like there is a broken association
with what ever call Sketchup is trying to make.
Can you give me more info on what that call is? I can try looking it up.
–Foz


#11

missing user rights in?:

C:\Users\<username>\AppData\Local\Temp\

installation and first launch should be done by “right-click < Run as Admin” in connection with the user account which will be used to run SU.


#12

Finnaly!
I uninstalled, and reinstalled as administrator, then ran as administrator.
The same “your offline” problem appeared, but when i opened the license
window from within the app, and pressed “add license”, it came back with
an error that the license was a previous version one. I entered the new
one and it worked.

You guys really need to work on that system.


#13

done.

am not sure why your system behaves so spooky… maybe a fussy ‘internet security suite’.


#14

This should be working now?


#15

What if I do not have an internet connection? How do I install the license? I have selected the advanced button and get the bummer message. My computer will never attach to the internet due to the environment in which I work.


#16

You may be out of luck, but I would try contacting the SU Pro support directly - they may be able to help.

Anssi


#17

than do an offline activation by the following procedure:

• open the license section of the SU welcome dialog shown during progam launch (or by “Help > Welcome to SketchUp… > License”)
• below the license entry box open “Advanced”
• hold the SHIFT key and click in the grey space below “Back to Simple Licensing”
• the “Host ID” (= MAC address) of the system should be displayed
• contact your supplier by providing the Host ID, your serial no and your name/company
• the supplier than will provide you in reply with an according “SketchUp.lic” license file for activating your license of this system

Win: if “Back to Simple Licensing” is missing or the Host ID not shown (can be finicky) open the Windows console by searching/launching “CMD”(.exe) and input “ipconfig /all”, the “Physical Address” shown is the MAC address required.


#18

I can get all of the information needed as described in the email. Unfortunately I am the system administrator and not the purchaser of the software. The person that made the purchase is not available and I am uncertain of who to contact as the “supplier” for the license file. Any ideas on how to resolve this?
FYI as you described, I did not get the simple licensing option and had to do the command line option.


#19

should be easily to find out by either checking your invoice or your regarding license email, if bought directly by Trimble click on the link “supplier” above.