Sketchup Pro 2015 won't let me add a license


#1

I bought a license for 2014 and I upgraded it to 2015 pro. I downloaded the 2015 pro, but the program won’t let me even use it. An error comes up when I click on the add new license button so I can’t type the license in or anything. It doesn’t let me click on the “start using sketchup” button either. How can this be solved?


#2

What is the exact error that comes up?


#3

I am having the same problem. Here is a screen shot. The text boxes are missing…


#4

Ditto here but with the Mac version.

It seems you use a web panel to do the registration and the page it links to is either not there or the redirect is not working properly.


#5

Im having exact the same difficulty here,
hope somebody comes up with a good solution.


#6

Same problem at our office. Trying to add new licenses we purchased.


#7

Ty here, sorry for this issue everyone, we are working with Engineering to get this up and going as soon as possible. We will update here as soon as we have a resolution. Thank you for your patience!


#8

I found a solution, at least for me. Maybe it will work for everyone else. I had to manually go into the firewall settings and tell Windows Firewall (in my case Windows, I am not sure how to do it on a Mac) that Sketchup 2015 existed on the system by creating a new rule. I would have thought that the installer would have done this, it did for Sketchup 8, 2013, & 2014, but not for 2015… Then I needed to allow all connections for this new “sketchup 2015” rule. After I did that, it worked. It worked right away for the Surface Pro, I needed to restart my desktop computer before it would work on that machine. I hope this helps.


#9

So we had a slight hicamurp this morning relating to the Add License feature. It has now been resolved. Please update here if you are seeing any further issues.


#10

You said the issue is resolved but I am unclear on what I have to do. How can I update my program so that it works?


#11

If you are having any issues downloading/installing/authorizing SketchUp, please check this knowledge center article - http://help.sketchup.com/en/article/13688


#12

I have downloaded the install file again and reinstalled after you said the issue was resolved but I am still having the same error.


License page not loading in SketchUp, can't add license information
#13

This may be an issue with cookies and/or cache on your computer. Please clear all cookies, especially on your default browser (IE for PC and Safari on Mac).


#14

That worked for me, Thanks.