SketchUp 2015 cannot access licensing

I tried add SketchUp 2015 license but button is not responding, it seems to be license server not available. What’s your advice for me? Does support team need my license to try?

We have been fixing issues with the license system, and things are improving, but I know that 2016 licenses are failing for some people. It isn’t the license, the same one may work for someone else and not for you. That’s the case for my own 2016 license.

2017 seems to be working ok, but I’m not surprised if 2015 is also falling. 2015 doesn’t even run on Mac now, which makes testing that a bit harder.

Anyway, I will pass on to the team that is investigating this that the problem is happening with 2015 licenses as well.

I’ll add my hat to this ring. I have 2015 Pro and I have one space left on my license. I am attempting to switch my license from a laptop to a desktop. The first (red) button to remove the license sends you to the “are you sure” page but the second (grey) ‘Remove License’ button does not work.

Any help in getting the program to remove the license would be greatly appreciated. Thank you.

If you managed to remove the license ok, adding it would still fail at the moment.

Thank you, sir. My client just installed SketchUp 2015 on Windows OS.