3D warehouse requires internet connection

I am also experiencing the same problem. I can’t access 3D warehouse for hours now. I also did what you suggested and did not work. Any other suggestions?

hi. you fixed it already?

Sorry, but i haven’t sorted the problem. I am using a time consuming work-round.
Using your internet browser, bring up 3d Warehouse. Find the model you want. Click Download then choose the Collada file option and download it onto your computer, then unzip the file.
In SketchUp. Go to File > Import > then go to where you downloaded the file to, usually Downloads >
click on the file, if then you find more than one item in the folder, click on the .DAE file. The item should then appear in your SketchUp model.
Not a cure to the problem and time consuming, but a work-round, until someone comes up with something.

1 Like

thank you so much, will do this for the time being

You shouldn’t need that work around in SU2021 or in SU2018, for that matter.

I have SU2018. Nothing mentioned on the ‘3D warehouse requires internet connection’ has worked for me.

But if you are going to the 3D Warehouse in your browser to download files, why aren’t you just downloading the SketchUp 2018 version of the file? Why are you downloading the Collada file and importing the .dae file?

Screenshot - 7_15_2021 , 10_28_03 AM

So there has to be something different on your computer that prevents you from accessing the 3D Warehouse within SketchUp. It works for others so what is different between your computer and theirs?

Did you install SU2018 by right clicking on the downloaded installer and selecting Run as administrator? Have you tried repairing the installation using that method?

Thank you for replying. Sketchup is running as administrator.
This problem first occurred about 3 months ago, but I could still access 3D Warehouse via the Components Box. After about 3 days it rectified itself without me doing anything. This time, I can’t access the 3D Warehouse via Components Box.
Your final question. ’ … so what is different between your computer and theirs?’ your guess is as good as mine!

That’s not the same as using Run as administrator when installing it.

Why don’t you at least try repairing the installation as I suggested. It might help. Certainly won’t hurt.

Thanks again.
How would I go about, trying to repair the installation as you suggest?
Also what could have changed to stop 3D Warehouse working initially, then repair itself, then stop working again? Any ideas, I made no setting changes.

Find the downloaded installer. Presumably it’s still in your Downloads folder. Right click on it, choose Run as administrator, choose Repair when it is presented.

It could be related to a Windows update (that’s pretty common) or the need for an update to the browser.

Checked. SketchUp Pro 2018 is using Run as administrator.

I already told you, that’s not the same as running the installer using Run as administrator.

This what I meant. The installer using Run as administrator. Apologize for the mix-up.
Browser up to date. Thanks anyway.

I have the same issue and have tried all the above-mentioned solutions to no avail. I, too, am running SU2018 Pro and have repaired it as administrator and run it as administrator. I can access the warehouse with Chrome and download files, but still get the internet required error in SU when trying to connect via components. I have this issue with both my machines.

Check if this works:

#MikeWayzovski - That is the correct solution as you stated for SU 2018 since the original line in the i18n.dat file, ONLINE_TEST_URL=“Google” refers to a url that give a 404 error. I changed my i18n.dat file to use ONLINE_TEST_URL=https://www.bing.com/ and that fixed it after hours of searching. Thanks

#MikeWayzovski - This is the corrected version of my post.
That is the correct solution as you stated for SU 2018 since the original line in the i18n.dat file,

ONLINE_TEST_URL=“http://www.google.com/ncr”

refers to a url that give a 404 error. I changed my i18n.dat file to use ONLINE_TEST_URL=https://www.bing.com/ and that fixed it after hours of searching. Thanks