SU 2018 no internet connection error

THANK YOU very much - this helped!!!

This morning I removed the /NCR and now it works again.

Qu es el NCR también me pasa pasa este inconveniente y no eh podido arreglarlo

Hi.
I have the same problem with internet connection since a few month.
Using SketchUp Pro 2018 on Mac Book Pro / OS 11.14 (Big Sur)
Is there also a way to solve the problem by changing the URL.
And where can i find it?
Best regards

Here’s a post I did for someone else using 2018 on Mac, and it appears to have solved the problem:

Pretty sure he used the bing.com text I suggested.

Perfect. Everything is fine now, Thanks a lot.

WOOHOO! This thread helped me solve this issue!

these didn’t work for me:
bing/ncr
google/ncr
google

As a recap:
Navigate to: C:\Program Files\SketchUp\SketchUp 2018\Resources\en-US
Modify: i18n.dat
With this URL:
[ONLINE CHECK]
ONLINE_TEST_URL=https://www.bing.com/

For your interest, ncr was a Google specific thing, to prevent you from being redirected to a different country’s Google page. It was bound not to work for Bing, and I suspect that it fails these days for Google as well.

So far this change to ONLINE_TEST_URL=https://www.bing.com/ seems to have worked for all Mac users who had the problem. It may be that macOS was changed recently to prevent http requests from getting through.

Thanks, that did it. So it was a change that Google made…

Thanks, this got my internet connection to SU back (I used www.bing.com)
I can now connect to Generate Report, where I could not before change, but when it opens it shows:
ERROR: Uncaught ReferenceError: google not defined @/2018_generatereport.html?hl=en[14]
(after I click ok box) Template Manager then opens allowing me to “edit report” as normal.
When I try to “RUN” report this next error shows:
ERROR: Uncaught ReferenceError: google not defined @/compiled.js[155]
(after I click ok box) It freezes on “Generating Report…”
Please advise on what I might try to Generate Report at this stage
Thanks

Thank you this worked for me.

None of the above options worked for me. Was accessing the 3D warehouse fine until a couple of days ago. Internet is working fine. Any other solutions?

Got it working after I cut the file from the folder it was in, placed it on the desktop, modified and saved it, and pasted it back in the folder.

Won’t allow me to modify it in the folder it is in, and won’t work with a copy of the file, you need to cut and paste the original file to the desktop, modify it and put it back.

Working with ONLINE_TEST_URL=http://www.bing.com

If you’re using SketchUp 2018 as your profile says, you’ll no longer be able to access 3dWH from within SketchUp.

That URL should include https, not http.

1 Like

Oh ho ho! That’s news I’ve not heard :wink:

This worked for me, thankfully, using https://www.bing.com and editing the dat file on desktop just as described above. Being able to Geolocate a model is mission critical for business…Thank you!

For your interest, I did go on to post this Known Issue, in the hope people will find the solution quicker:

https://forums.sketchup.com/t/sketchup-thinks-you-dont-have-an-internet-connection/170862/4

1 Like

Google didn’t work, but bing did!

Many thanks.

That fix worked for me - thanks!!!
Closed Sketchup 2018 - in C:\Program Files\SketchUp\SketchUp 2018\Resources\en-US located file i18n.dat - opened with Notepad++ - replaced “Google” by “http://www.bing.com” - restarted SU2018 = it worked - Thanks again!!!

Got the same problem. Still fighting. There still is message “3D warehouse requires internet connection” when i click on 3d warehouse icon.
BUT! When I go for File>3d Warehouse>share model i can access 3D warehouse and download models!!
This is weird AF. Can some one help me.
Changed to https://www.bing.com