3D warehouse requires internet connection

Hi there,
I keep getting the message “3D warehouse requires internet connection. Please connect and try again”. However, I have internet connection that is working. This problem has just appeared. I have tried to solve this for hours today to no avail.
I have also tried signing out of my account in sketch up but I also get the message “unable to connect please check internet connection”.
Can anyone offer some solutions please? Thank you!

Can you access 3dwarehouse.sketchup.com in a browser?
You might wanna repair the installation.
Best to download the latest version, first.
Then rightclick on the downloaded installer file and choose ‘run as administrator’ when prompted, choose ‘repair’

Thank you very much for taking the time to respond.
I have tried and completed all those options however the problem still exists.
…baffling!

And can you access bing.com in a browser?

This is also a support case, and no, he can’t access bing.com. At the moment I’m forgetting how you can make Windows block bing.com, in order to then stop it from being blocked.

Anti Virus software?

Hi,
Thankyou.
I tried again and yes I can access bing.com but still not 3D warehouse nor extensions. Still can’t even log out of sketchup from sketchup.
Sunday day here in Australia, will try a few more things today…anti virus and uninstalling last windows updates.
…???scratching head…

Ok, new idea…

If it is just difficulties in signing in or out, try setting your default browser to be Chrome or Firefox. There are some issues with signing in if you are using IE or Edge.

Hi Colin, thankyou for the idea. Chrome is my default browser and the problem isn’t just signing in and out. It’s also the 3D warehouse and extensions, therfore internet connection with sketchup.

But you do have access to this forum (forums.sketchup.com)
How did you get here? Other machine?

Hi Mike, yep access to the forum, access to normal internet etc from the same machine. Its just sketchup - 3D warehouse, extensions and logging in and out of the program.
…crazy!

It takes a while for me to run out of ideas!

Both warehouses do get upset if port 443 is blocked. Can you test to see if it is blocked?

In the command prompt window you can try this:

telnet extensions.sketchup.com 443

If it gets locked up, or shows any error, the port is blocked. If the screen clears, then the port is ok. Ctrl-c will get you out of telnet.

If telnet isn’t enabled on your system you can get to its checkbox to enable it by opening “Turn Windows features on or off”.

Have you tried by disabling your firewall temporarily? Also do you have more than one security program running?

Thanks everyone for you help. I got it!!!
Ended up being a simple solution…of course! My router had gone into a limited mode and while I had some access it was not functioning properly. Just turned it off and back on and all is working now.

I really appreciate everyone’s input and ideas!
Enjoy the rest of your week.

1 Like