Sketchup 2015 says I don't have an internet connection but i do!


#1

when i try to open 3d warehouse or extensions, a message pops up saying “could not connect to the 3d warehouse” or “the extension warehouse requires an internet connection. please connect and try again.” and plugins won’t load. ive gone through trouble shooting. sketchup 2014 worked great, unfortunately i deleted it after downloading 2015. HELP


#2

Does this help?
http://help.sketchup.com/en/article/3000044


#3

What OS? What language? We don’t want to hang you, so we do a ping to tell if you’re online. You can change that ping address, but it depends on your language and OS.

-b


#4

thanks for answering. I’ve looked at this but i’m not sure the answer is there. as i said 2014 worked with connecting to the internet.
I would add the “ports” that SU needs just to see if that helped, but i need to know how to do that.
how would i add the “*.sketchup.com” (permission to visit al sub-domaines?
any help is appreciated


#5

i have windows 7, 64-bit


#6

Did anyone find a fix for this error. I also am having trouble with sketchup pro 2015 connecting to the internet?


#7

#8

Elaborating on @sketch3d_de comment:

SketchUp requires uninterrupted access to the internet for features such as the 3D Warehouse, Add Location and Extension Warehouse. To ensure connectivity you may need to adjust settings in your Firewall, Proxy or Internet Security software for your network or computer. Please see this article for the complete description and list of steps to take to correct the problem of connecting to the Internet through SketchUp Pro 2015: . Also, this article: http://help.sketchup.com/en/article/3000074

Also note that you will need to have the latest IE or Safari installed for SketchUp to work. You may not use IE/Safari, but SketchUp does. Double check your browser version at the same time you’re confirming the settings.

To set your Security to Medium in Internet Explorer you can open Internet Options, go to the Security tab and adjust the slider to Medium and then uncheck the Protected Mode. Be sure to restart SketchUp after making your changes.


#9

Why isn’t the information on making sure IE is up to date the first post?

If SketchUp can ping the server for the license / update check why can’t it be signed into without IE 11? I guess I have to update… LAME.


#10

As with all software, the system requirements provide this information. You should always read and understand those requirements before you dive into using any software.

SketchUp uses Internet Explorer on Windows machines because, among other reasons, it is the only internet browser that is included with all Windows OS installs.


#11

Might want to update this information. I couldn’t get a connection until I had the latest IE11 installed. IE9 isn’t supported anymore.


#12

Hello
I have the same problem, I have tried all the advices above but failed. Please help.
My systems is Windows 8.1, Sketchup 2017.


#13

My IE is IE 11.


#14

don’t crosspost, thx.