SketchUp says its not connected to the Internet so cannot access 3dWarehouse etc

I have a license for version 2018 and can no longer access 3d Warehouse, Extension Manager etc.

I tried the suggested solutions but since I work from home I don’t have an IT manager. I cannot determine if SketchUp has access to the listed ports. I cleared my cookies, cache, dns cache etc.

I can connect to the warehouse outside of SketchUp just fine just not from within SketchUp and not since the last week or so.

Help please,

Other recent posts confirm that v2017 and more recently v2018 no longer support built-in access to the 3dWH or EWH.
Although you can still access the sites through your web-browser, and then download and manually add the downloaded SKPs into your model or install the extensions from their downloaded RBZ files.

This has been resolved already, see here:

Thanks. That’s what I was afraid of.

Allen

It continues to work for me, after the fix from the other day.

Are you getting a mostly blank 3D Warehouse window, or are you getting no Internet at all?

Switched browsers to Edge. All fine now.

Weird. Came out of nowhere.

Allen

Hi Colin,

Very frustrating.

I’ve tried all the fixes I can institute from home without an IT person to check which ports I have assigned.

I own a perpetual license to SketchUp 2018 and as a retired architect, I mostly use SketchUp for hobby fun and small projects where I can charge a small fee. Not enough income to justify the yearly $300 license fee.

I discovered that within the last week or so, I was having difficulty accessing the 3dWarehouse and the Extension Warehouse. Sometimes it would connect and sometimes it wouldn’t. Now it never connects saying I need an Internet connection.

I changed browsers from Chrome (which I have been using for years without problem) to Edge. The first time I tried using SU with Edge as my default browser, everything worked as expected and I could connect to 3d Warehouse and Extension Manager. No problem. Hence my email saying problem solved.

I tried again later and could not connect. Both 3d Warehouse and Extension Manager both said I needed an Internet connection even though I verified that MS Edge was my default browser.

Wish there was a less expensive option than SU Pro for $300/year for retirees and long term SU users. I would accept a monthly charge of say $10-$15 much as Adobe charges for their monthly subscription to Photoshop and Lightroom called their Photography Plan.

I appreciate that Trimble needs cash flow to maintain and improver SU and monthly subscriptions are becoming the new normal but $25/month seems a bit high for me.

Can we find a compromise?

Allen

Allen Weitzman

aweitzman.ret@gmail.com

See if what I wrote in this reply helps your situation:

It would be nice having a ‘lifetime achievement’ license

Check for non profit license

For sure

Allen

Allen Weitzman

aweitzman.ret@gmail.com

Hi Colin,

I think I understand your suggestion.

I was able to find the file and make the change but cannot save it as I am not the administrator. I thought I might simply make myself the administrator but I cannot do that either since I don’t know the administrators password.

The company that sold me the computer and answers all my technical problems is the apparent administrator which they use to access my computer remotely and make changes to the system to solve whatever problem I am having.

I’ll have to wait until Monday and ask them to upload the changed i18n.dat file and see if that solves the problem.

BTW, what does the /ncr mean?

Allen

Allen Weitzman

aweitzman.ret@gmail.com

I said in my other post that you may need to copy the file to your desktop to edit and save that copy. But, that could still leave you will needing an admin password to then replace the original file.

Something is different about your network or security settings. If you tell your IT people that the problem appears to be that applications cannot check an http URL, they may be able to make a change to allow that, and then you won’t need to edit the i18n.dat file. But, it would be interesting to know if editing that file does solve the problem.

/ncr is No Country Redirect, and it was a way to ping the US google.com, and not have the request be redirected to another country. It may do no harm if it’s there, but I’m not sure if it’s still needed. Setting the test URL to be https://www.bing.com, or to any web site that you know loads every time, and quickly, would do just as well.

Thanks. I’ll certainly let you know how this turns out Monday.

I did copy the file to my desktop as you advised, made the change but I wasn’t allowed to copy the changes file back into place without having administrator rights.

Allen