3D Warehouse Not Responding

Thank you. Can you tell me where is the best place to download ThomThom CleanUp3? I looked on Extensions and it 's not there. It looks like SketchUcation has it available - but I’m not sure if that’s the best place to get it.

It’s in the Extension Warehouse.

1 Like

Thank you!!! I was looking for “ThomThom”. I just downloaded it.

1 Like

Anything specific I should check off here - or do the default setting suffice?

I’d check them all and see what happens.

1 Like

I don’t know if this is going to solve my initial issues with downloading models from 3D Warehouse. But you’ve definitely helped me turn a new leaf. I’m watching tutorials on how to make “smaller” models and lesson the impact of large models in my drawings by having them on separate layers while working on the model, etc…

Also I’ll get in the habit of cleaning up my models with CleanUp3. Thank you for all your suggestions.

1 Like

Here’s an example. I downloaded a randomly selected stove from the 3D Warehouse. The file size is shown as 40 Mb. It looks like this when I get it in from the 3D Warehouse.

I deleted the image of it and ran CleanUp3 on it and this is the report. Notice how much stuff is removed.
Screenshot - 6_3_2020 , 11_00_11 AM

This reduced the file size by a little over 33% but there’s more that can be done.

If this stove was going to be shown in a kitchen model, it doesn’t need any of the internal geometry at all but it’s there.

Look at the Outliner. Well, the top half of it, anyway.

There’s over 27 entities in just the wires that support the racks on one side. Details no one will see or care about if looking at a model of a whole kitchen.

The galvanized metal texture used on the outside is over 2 Mb.

My point is that by itself this is a nice enough model. I don’t think I’d buy a range with a galvanized skin but that’s me. If you were going to add this to a model of a house as it is, your file size goes up by 40 Mb. Now add similar sized appliances and furniture to your house model and you can easily get the file size to the point where it is unmanageable and your computer struggles to process all the data. If this range was something I needed to use in a kitchen model I would seriously gut the thing. It wouldn’t need any of the internal stuff, it doesn’t even need the feet in the back. And I’d either edit the metal texture to reduce the file size or use a better material instead.

I spent a little time doing further cleanup and reduced the file size more. It could still stand some simplification but the file size is now reduced by nearly 75%.

2 Likes

Wow! Okay. This is really an eye opener. Most of my files are in the range of 400 MB. I’m embarrassed to even admit that.

No need to be embarrassed. It’s easy to let them get out of hand unless you know what to look for. Clearly keeping things cleaned up as you go helps improve your working efficiency. It usually also makes it easier to make changes later on when they become necessary.

1 Like

When you search for something in 3D Warehouse there is a file size slider over on the left of the page. You could drag that down to a low value, and find the point where you still get a useful stove, but that isn’t so huge a file.

1 Like

Apparently you missed the point Colin.

1 Like

I’m guessing I did!

Lol. Still useful information that I didn’t know before. Thank you!

I too am having the same exact issue @mazzie504 since yesterday… were you able to resolve it? I’ve tried everything and I still can’t get any result from my search in 3D Warehouse. I’ve also written to sketchup but have not gotten any response yet.

See the following. It applies to SketchUp 2018, too.

1 Like

Do you think this will affect SketchUp 2018 Pro as well? My same issue just started yesterday (SE Asia time).

As I wrote, this affects SketchUp 2018 as well. If you read that thread you can see that @colin indicated that.

I don’t know if there’ll be any fix for SketchUp 2018 but my guess is it isn’t likely since that version has been out of support for a few years.

1 Like

Thank you @DaveR. So sad to hear that! They’re really forcing me to get the latest Pro version with annual subscription

As indicated in the first post of that thread you can still use the Components window and your Internet browser to access the 3D Warehouse.

Some good news. The issue that had been introduced by changes to comply with more recent versions of Chromium, has been fixed. SketchUp 2017 and 2018 are showing the 3D Warehouse window contents ok now.

2 Likes