3D Warehouse Gray Background + No Models

I have sketchup make 2017 and my 3D warehouse won’t load anything. It is a gray background and was working perfectly a few days ago. I uploaded an image of the error on the dev end.

That was reported earlier today. Not sure about the progress in getting it fixed, but when it is, I’m sure it will be mentioned in the other topic:

Hi Colin,
From your experience, what the timeline of something like this being fixed? I am creating renders for an employer and this task is time sensitive.

And you are using SketchUp Make? You should be using SketchUp Pro.

I used to do the renders on Revit and recently switched to sketchup. Do you have advice on the benefits of Pro?

Well the key things in this case are that SketchUp Make is not authorized for commercial use. SketchUp Pro is. And, since this is important for you right now, the 3D Warehouse works with SketchUp Pro.

SketchUp Pro has more tools and more features like CAD file import and export among other things.

Ah I did not know that, and CAD import would definately be helpful! Thank you!

1 Like

It can vary, and unfortunately for you, as the problem doesn’t affect any currently supported version of SketchUp, it may not have a high priority.

Note my suggestion in the other topic, you can still search for models in the Components panel.

Hi, I have Sketchup 2018 pro licensed, the 3d warehouse is not displaying anything for me too. Last time it worked for me was yesterday. Any solution yet?

You can always download via a browser.

Yup, but it is a time saver to have a direct download to model…

Use the Components window to search and download components from the Warehouse.

1 Like

Often it’s not that much faster in the long run because you regularly need to open and clean downloads in a separate file before putting them in your model.

this is true, but I sometimes download all i need in a file and just copy from there… ( i can see all the selections in 1 file)

I was only pointing out a workaround until it works again.

Thanks but it just shows the model, it still doesn’t download from the pop up…all button seems frozen, only reacts to the “upload” button

Yes mate, seems the only way at the moment. Thanks!

So this doesn’t work in 2018?

Sorry, it does download from the " components". I thought you were suggesting to activate the “3d warehouse window” from the “components”.

No. I was suggesting exactly what I showed.