3D Connexion driver Support for 2021

Well it helped me since I can’t get any help from 3DConnexion.

I’ve been trying to get my space mouse working since August 4th.

Response from them on 8-12-20

we have not given up here, for sure not.

The problem is that our main developer is currently on vacation.

From me on 8-27-20

Almost 2 weeks later. Do you have an update?

No response…

From me again on 8-28-20

Is there no fix?

Bought a new computer in November and tried installing space mouse. Crash on 2017,2018,2020.

Emailed again and called on the phone. Finally middle of this week I actually talked to a real live person and he promised they would contact me today. I tried contacting them today without a response.

I understand the driver probably shouldn’t have been posted above, but at least I’m able to use my space mouse in 2021 now :slight_smile:

I’m pretty disappointed with the lack of support so far.

I can’t disagree with you Neil and if they hadn’t emailed me the driver this morning I would have jumped on it, but it still shouldn’t have been posted.
Particularly as @ngomes who works for them, has responded in the thread and hadn’t posted it.

1 Like

Wow now 10 minutes after I post that nasty response out of frustration I finally figured out the problem! :bulb:

I had renamed the SketchUp.exe to Sketchup 20XX.exe so my my tooltip in the start menu would show the year. Changing it back fixed the problem.

image

Got a different solution now.

image

@ngomes
Why not post the driver here for people’s convenience until you can make a public release?

They haven’t posted the driver on their own forum, so I doubt they want to post it here.

1 Like

I have no "plugin "folder in 2121 (programdata/sketchup/sketchup2021/sketchup)

All previous versions do.

The only change is the subscription model I’m using for 2021

Waiting for update for 3D Connexion

There isn’t supposed to be a Plugins folder in SU2021 unless some application creates it. On my PC I have App Data/…/SketchUp/Plugins because it was created by Vray for Sketchup. Since I haven’t installed Vray in 2021, there’s no Plugins folder.

If you had previously used SU Pro 2020 with the 3Dconnexion drivers, you should still find a “ProgramData/Sketchup/Sketchup 2020/Sketchup/Plugins” folder.

(Assuming you are on Windows…) You would copy only the file 3DxSketchUp.rb and the folder 3DxSketchUp to the new “…/SketchUp 2021/Sketchup/Plugins” folder. However, at this point the drivers are not compatible and you get a Ruby console popping up during launch to tell you this:
SketchUp 2021 Load Error 2

As noted above, if you sign up to their site and request the driver they will send it to you, and it does work. But they offer it with the warning that it shouldn’t be relied on for commercial work.
And it installs without having to know anything about which folder etc

I had the original SpaceNavigator (with the USB cord, not the Compact version) stop working this year as well. Turns out they no longer supported the model I had :disappointed:
I had also purchased the wireless version that I carry around with my laptop, and it still works like a champ. The battery last so long, and the wireless connection is so reliable that I now use it exclusively.

Anyone want a ‘USB-powered, puck-shaped’ paper weight??

1 Like

I have usb and wireless versions, all work fine.

Confirm this is Mac only, or Windows as well??

Mac actually works with the current drivers, the new mac driver they are talking about is for Big Sur.
I am windows exclusive and that is what they sent me and is working.

1 Like

My SpaceNavigator USB worked for the most part, but would periodically stop all scrolling, rotating and zooming for a couple of seconds before resuming full control. Very annoying.

No issues whatsoever with the wireless version.

Just fired off a request to 3Dconnexion Support. Thanks for the info :+1:

1 Like

I just noticed a funny thing: I have done nothing yet to make my Space Navigator to work with version 2021, as I have been waiting for their new drivers, but I just noticed that it zooms in and out without any plugins installed.

were you referring to windows or mac. I have windows - if so can you show me how?

Thanks anyway,
Billy

That may be due to their default input events with no specific adaptation for SketchUp.

10.15.7 Mac with SU 2021 Pro (classic !) and the 3D mouse works as well as it ever has, actually smoother.