3D Connexion and SU2018

After installation, moving plugins, deleting SU 2017(I shouldn’t have!), I found out that the 3DConnexion mouse is not working. Installed latest drivers, then remvoed driver and reinstalled, still not working.

Shall I wait for an update from 3DConnexion or am I missing something?

I’m on a Windows10 64-bit.

No, you can copy the files manually from SketchUp 2017 plugin folder to SketchUp 2018 and your you 3D Connexion will work perfect.

You can find this files inside the global plugin folder and not your personal one.
On Mac: /Library/Application Support/SketchUp 2017/SketchUp/Plugins

Unfortunately I am on a Windows 10, and the 3DConnexion plugin resides in the softwares folder on Program Files. I’ve tried copying that folder back into sketchup plugins and changed names as required to find the files and load them, but I still get errors.

Thanks a lot, I can use again :sweat_smile:

It isn’t a good idea to move plugins/extensions from an older version to a newer one. Best practice is to install them fresh so you have the most recent versions.

Right in general, but in this specific case the 3D Connection installer won’t install to 2018! Until 3D Connection gets around to updating their installer to include SU 2018, one has to copy the files manually!

1 Like

Not Program Files but ProgramData:
C:\ProgramData\SketchUp\SketchUp 2017\SketchUp\Plugins

3dConnexion Space Mouse no longer a supported input device? Doesn’t work in SU18Pro but still works in SU17Pro…?

It does work, but the 3DConnexion installer does not place drivers into the 2018 plugins folder. You can copy the 3DConnexion rb and folder from the 2017 Plugins folder to the 2018 Plugins folder, then you shoudl be good-to-go!

1 Like

To be more accurate, the files reside in
C:\ProgramData\SketchUp\SketchUp 2017\SketchUp\Plugins
The files to be copied over to the corresponding place in the SketchUp 2018 folder are:

Using the folder in ProgramData gives access to the 3DConnexion device to all users of your computer. Usually extensions reside inside your personal profile.

I’m afraid there is no option for this on a Mac. No 3DConnexion rb file in Mac OS X ~/Library/Application Support/Sketchup 2017/Plugins folder.

3D mouse not working on Mac, and no driver update as yet… ;-(

I know almost nothing about current Macs. My wife has one but I rarely get to touch it :slight_smile:
Did you look for the 3D Connexion files in your personal extensions folder?

they put it in the HD Library…


1 Like


I can confirm that moving the files and folder in:
/Library/Application Support/SketchUp 2017/SketchUp/Plugins
… to
/Library/Application Support/SketchUp 2018/SketchUp/Plugins
(you may have to create a new SketchUp 2018 folder) got my 3D mouse working.

1 Like

you can also just r-click >> Duplicate which gives you

/Library/Application Support/SketchUp 2017 copy

then r-click >> Rename in Finder to

/Library/Application Support/SketchUp 2018

all the subfolders will be inside…


1 Like

Thank you for this “life saving” direction.
Being a lover of SketchUp, but as a design/fab/fix solo user, I am not as well read about the idiosyncrasies of the latest version. and often not the current version :wink: Thanks for the Help!

According to the solution, I’ve just copy/paste the Plugins folder from the 2017 to the 2018 SketchUp folder and all is good. :slight_smile:

I tried everything below, can not get to work.
Please can we have more detailed instruction for Win 10 64 bit
Thanks JB

• quit all running SU versions
• enter “%APPDATA%” in Windows search command line (w/o quotation marks of course)
• go to sub-directory ".\SketchUp\SketchUp2017\SketchUp\Plugins\ "
• copy 3D Connexion stuff (“Strg+C”)
• go to sub-directory ".\SketchUp\SketchUp2018\SketchUp\Plugins\ " (if not existent do create)
• paste 3D Connexion stuff (“Strg+V”)

3Dconnexion : Download Drivers

That was the critical info I required!
Found the file and folder in the HD Library, rather than the User Library, copied them into the Sketchup 2018 plugins folder in the User library and boom! Space Navigator Mouse working with SU 2018!
Yay and thanks for the tip!