Space navigator and sketchup pro 2018


#1

Space navigator doesn’t work in Sketchup Pro 2018


3D Connexion Mouse not working
3Dconnection No funciona con Sketchup 2018
#2

from the 2018 thread…


#3

I can’t find 3DConnexion rb in …AppData\Roaming\SketchUp\SketchUp 2017\SketchUp\Plugins?! There is however a
directory in …AppData\Roaming\3Dconnexion…?!


#4

I have the same question - except on a Mac. Not sure where to find the 2017 3D Connexion plug in… or where to put it. Thanks in advance!

By the way - I’d just reinstall the program on my Mac but 3Dconnexion.com is down.


#5

Must have been a temporary outage, as I downloaded the latest driver (10.5.0) today. However, since SU 2018 was released after this driver, the driver installer does not know about it and only hits versions up to SU 2017. Until 3D Connection gets around to another update, you have to copy the files by hand from the SU 2017 folder (this has happened with nearly every new release of SketchUp - thank you 3D Connection!). Because 3D Connection installs the drivers to be shared by all users, you will need administrative privileges and to enter the admin password to set things up. You need to copy the 3DxSketchUp.rb file and 3DxSketchUp folder from

/Library/Application Support/SketchUp 2017/SketchUp/Plugins/

to

/Library/Application Support/SketchUp 2018/SketchUp/Plugins/

I can’t recall right now whether that folder path is created by SketchUp or if I had to create it…sorry!


#6

Wonderful - thank you so much!

I made the directory SketchUp 2018 and copied the files over. It wasn’t working until I went into…

System Preferences | 3Dconnexion | Tools

…and then clicked on Install Plug-ins.

That was while still using 10.4.4 - the site is still down!


#7

Re 3DConnexion on mac high sierra and skp 2018…I have installed plugins and rebooted etc…no work for me. Cannot find plugin in plugins folder in skp 2017 or 2018 although it is in my skp 2017 extension manager and it does work in skp 2017


#8

I’m using a Mac and found the 3DxSketchup folder in HD/Library/Application Support/Sketchup 2017/Sketchup/Plugins/…
created in a new folder named “Sketchup 2018” and copied the folder named “Sketchup” from HD/Library/Application Support/Sketchup 2017/ and pasted it in to “Sketchup 2018”.

There is also a Library folder for each user - you will not find the 3DxSketchup folder there.


#9

Plugin Transfer to newly created 2018 Plugin folder worked to communicate with the device, but now all of the controls are inverted. Any ideas to correct that setting?
Did anyone else have that problem?


3D Connexion Mouse not working
#10

SOLVED!
Camera was in Object Mode and not in Camera Mode! Thanks for all the help folks!


#11

Thanks…that works…I was previously going to library/application support etc via GO/library/application support etc which did not include 3DxSketchup under any plugins from any year…so secret is to access via HD/library/application


#12

My 3DConnexion Mouse works fine in 2017 and I am in AppData\Roaming\SketchUp\SketchUp 2017\SketchUp\Plugins but dont have a file in there that says 3DConnexion rb in it. In fact I have nothing in there that comes to mentioning a 3D mouse of any kind.

Am I missing something?


#13

Yes. This thread seems to be mostly about the Mac version, and the correct file location has been explained many times in the threads discussing the Windows version. In Windows it is not in your personal profile but in the general ProgramData folder:
C:\ProgramData\SketchUp\SketchUp 2017\SketchUp\Plugins

There is a 3DXSketchUp folder and a 3DXSketchUp.rb file there.

Copy these over into the corresponding C:\ProgramData\SketchUp\SketchUp 2018\SketchUp\Plugins folder and it should work.


#14

My system is win10, I solved this problem by Copying 3Dxsketchup.rb and its folder to program files\ sketchup\ sketchup 2018\ shippedEXtensions. For your reference.


#15

You should move the 3dconnexion file/folder to the ProgramData directory. Future 3dconnexion driver updates will be looking at that location to add/update/remove stuff. As it stands now, you could have 2 versions of the same extension with unexpected consequences at some point in the future.


#16

My Windows 10 Home directory doesn’t have a library/application Support/SketchUp 2018/SketchUp/Plugins/

Neither folder for SketchUp 2017 Pro or SketchUp 2018 Pro have a ‘plugins’ folder. There is a “infoplugin” folder, but it has only *.dll (windows dynamic linked library) in it.


#17

Sorry, the post above should read “ifcplugin” not “infoplugin”.


#18

Yes, Windows doesn’t have same folders as a Mac. See the instructions for Windows in other replies in this thread or others about this same issue. Note that the ProgramData (and the corresponding AppData in your personal profile) folders are hidden by default.


#19

To view hidden folders in Windows, open a folder dialog. Go to Organize > Folder and search options > View. Under HIdden files and folders, enable the show option.


#20

Thank you guys for suggested solutions. My Space Navigator started to work in Sketchup 2018 Pro, though I have a very annoying problem. Space navigator works yet only along one axis at a time. I can either tilt, rotate, lift, zoom, etc. but only one operation at a time. I can’t simultaneously rotate and zoom or lift and rotate for example. Is there a way to fix it?