2020 Pro Installation keeps failing

Hello all, I was upgrading to 2020 Pro from 2019 Pro on a nonprofit license. I downloaded the wizard file like normal and began the install. Before it even installed it said that it needed to “restart”, this is when it all started going south. When it restarted, it said that “the wizard was interrupted before SketchUp 2020 could be completely installed” with an option below to “finish” the installation. When I hit that virtually nothing happens. There is an installshield file left on my desktop as well. I don’t know what I could have done wrong, as they don’t leave much room for error. Please help. I run a nonprofit that give free tiny homes to homeless veterans. Since the"rona" I am stuck at home with a ton of work to do and no SU!

To begin the installation did you right click on the downloaded installer file and choose Run as administrator?

No sir, I will try that now.

Same thing sadly. I really appreciate the suggestion!

1 Like

Do you have something running like firewall or anti-virus software that might be picking on SketchUp’s installer?

I have indeed switched to AVG (free) since last time I updated my license. I can’t say whether or not this is interfering as honestly, I’m surprised I can tie my shoes.

Perhaps you can tell AVG that SketchUp is one of the good guys and it’ll let the install go through. (Remember to right click on the installer and choose Run as administrator when you do install SketchUp.)

I can show you how to tie your shoes so they’ll stay tied unless you want to untie them. :smiley:

1 Like

I just use super glue so they look tied. I tried to go offline, disabled AVG, and retried installation again. No dice. This sucks.

The SketchUp installation normally requires an internet connection.

I downloaded the full version that “let’s you do it offline”. The other link that I downloaded won’t work anymore. It just downloads as a blank page looking icon.

Where did you download from? Try: https://www.sketchup.com/download/all

I was using the link from my retailer, but I tried that one with no effect.

Who is the retailer?

Have you tried a cold reboot of the computer? Unfortunately the message you are getting doesn’t seem to provide a whole lot of information. Maybe @colin would be able to sort you out.

I did a system restore to earlier today and this is what happened as soon as I started up.

That’s new information. I wonder if @DanRathbun would have any insight.

I tried deleting all of the C++ packets and tried again, no luck.

Are you really offline? The installer is trying to download the required packages from the Microsoft website, and apparently failing.

Thank you for jumping in on this, that was from a different attempt. I was just coming back on again from a system restore restart when I got those last messages.