2020, 2021 Plugin Loading errors

hi everybody
I have the same load error message with all SKU version now. Up to now; I solve the problem by rebooting my computer. First boot I am getting the load error message and at reboot the load error message disappears and curiously all my plugins are loaded even those that I do not use regularly…
they appear diagonally on my screen in cascade… Strange? Has somebody an explanation ?

On PCs installing SketchUp’s installer exe file using the context-menu “Run as administrator” method is the recommended way to set permissions properly.
Having SketchUp’s exe set up to always run as admin can mask the incorrect installation problems, but there will be hidden issues… for example, drag-n-drop into the SketchUp model’s window will no longer work because Windows Explorer always runs with normal security permission levels and Windows prevents any app running at that level to interact with one running at an elevated level - as your modified SketchUp app will be…
If as a user you have admin-powers it’s irrelevant, since the apps’ exe files run much the same…

It seems that this is no definitive solution to this problem. Can some one from Trimble comment on this and provide an answer once and for all?

We’ve been unable to reproduce this in any way so far. Need to collect more information.

I got a couple of requests for those that have this issue:

Test if .RBS files load

  1. Download this file: load-test.zip (158 Bytes)
  2. Extract the load-test.rbs.rbs files into your SketchUp Plugins directory; C:\Users\<YourUserName>\AppData\Roaming\SketchUp\SketchUp 2021\SketchUp\Plugins
  3. Launch SketchUp
  4. Copy and Paste the list of errors (I want to see if the .rbs file appears in the error list)

Generate a report of loaded DLLs by SketchUp:

  1. Download ListDLLs utility: ListDLLs - Windows Sysinternals | Microsoft Docs
  2. Unpack that zip file somewhere on your system. (Lets say into your downloads folder, something like; C:\Users\<YourUsername>\Downloads\ListDlls)
  3. Launch SketchUp
  4. Launch a Command Line window (Win+R, then cmd)
    image
  5. Change directory to where you extracted ListsDLLs;
    image
  6. Enter this command into the command line window:
Listdlls.exe sketchup.exe > sketchup-dlls.log

image
7. Send me the sketchup-dlls.log file to me. (Post here or via private message)

This log file will list all the DLLs loaded by SketchUp.

Description:
When SketchUp opens, there is an Load Error for the 4 default extensions of Advanced Camera Tools, Dynamic Components, Sandbox Tools AND Trimble Connect.

Started from:
Just started getting the Load Error on SU2020 after a botched install of Enscape For Sketchup. Uninstalled and reinstalled as administrator for Enscape…(that does not show load errors). When loading Sketchup, got the Load Error on the DEFAULT EXTENSIONS.

Actions taken:
Repaired Sketchup 2020, reinstalled Enscape For Sketchup, then uninstalled extensions through Extention Manager > Manage. Verified that the files were gone from the Plug-ins folder. Can get several of the Load Errors to go away (if the extension is disabled or uninstalled first) when opening a new Sketchup file, but not all do. But closing app and reopening gets the previously erroring files to still error.

However, if the extensions start as Disabled when Sketchup closes last, when reopened the Load Error messages do not show up. Then going into Extension Manager and “Enabling” those extensions then there are not errors opening files. Closing app, then opening a file, the Load Errors still occur.

Also, as of today, there were two updates for the Dynamic Components and Trimble Connect extensions but applying them did not remove the Load Error. If I uninstalled Advanced Camera Tools separately and then reopened the app, the Load Error went away but uninstalling the other extensions, still brought Advance Camera Tools extension back into Error state.

No answers but thought the behavior that I am seeing might help to diagnose it.

Update: After I just posted this entry, I had gone into Extension Manager > Manage and marked all the 4 default extensions as Disabled (to get a screenshot)…I don’t think that I hit apply. Then I wrote the long post above. After 4-5 minutes, I reenabled the extensions, applied and closed out to get a screenshot of the errors. When I got back in and opened the test file I had been using, the Load Errors did not appear.

Interesting, you started getting errors from other extensions after a troubled installation of Enscape?

If you open the Ruby Console before enabling the extensions, do you see errors appear there? We only pop up a dialog with errors upon startup. (Though, it probably would make sense to do the same when enabling/installing via Extension Manager.)

So you are not longer getting any load errors? And you have all your extensions enabled?

I’m getting the same error. It’s been happening for a while (since a recent Windows or Sketchup update perhaps). I’ve been ignoring it as I don’t need to use the affected extensions. However just bought a 3DConnexion Space Mouse and need to get it’s extension working. Sadly it won’t load along with the 4 “built in” extensions as described.

I’ve tried everything, uninstalling, deleting folders and registry settings as described in the posts above. Reinstalled and run App as Administrator. Nothing seems to help.

I’m assuming these are Ruby extensions? Is it possible that the Ruby installation is somehow broken by an update, hence the extensions won’t load?

Any ideas?

You shouldn’t run Sketchup itself As Administrator. Make sure you have run the INSTALLER ‘As Administrator’. If you didn’t, or are not sure, close SU, Layout and Style builder, and find the downloaded installer .exe file. Run THAT As Administrator, and choose Repair when offered the option.

If you have already tried that, or after you try it now, report back on the forum if it still isn’t fixed.

Yes, I was running the .msi installer as Administrator both initially and when attempting a Repair.

It doesn’t help and I still get the load errors.

I’m getting the feeling it’s Ruby related? Ruby console reports :

RUBY_VERSION
2.7.1

I’m wondering if installing a later version of Ruby might fix it as the problem seems to persist even after repeated uninstalls / delete Sketchup folders and registry keys.

The installer doesn’t do a great job and leaves many folders (mainly the plugins). I’m just wondering if it leaves the Ruby installation too (which is somehow broken by a Windows or Sketchup update?).

I have the same problem, the load-test.rbs file does not give any errors when starting. I’ve attached my sketchup-dlls.txt.sketchup-dlls.txt (10.9 KB). I hope that helps identify the issue. I’d really like to get this 3D Connexion Space Mouse to work!

Just to be 100% sure, as it is a common point of confusion, did you log on as yourself, right-click the installer and choose Run as Administrator? That is not the same thing as running the installer while logged on as an Administrator.

Yes, I right clicked to “run as Administrator” as instructed in the many previous messages. However it doesn’t help. It’s been unable to load extensions for a few weeks…I ignored it because I didn’t need the extensions at the time. However, now I need to use the extensions to get this 3DConnexion Space Mouse working.

Even after a full uninstall there are many Sketchup files and registry settings remaining. I’ve tried to find all of these and manually deleted them before reinstalling again (using Run as Administrator) but the same error occurs.

It suggests to me, as an experienced C# programmer, that something else (Ruby?) gets installed but not fully uninstalled by the installer? I’m thinking it’s something to do with Ruby as those are the files that cannot be loaded or run.

Possibly your OS install is corrupted in some way ? When I first tried to install the 3d
Connexion drivers, they would not work. A format and re-install of the OS took care of that.

It’s not just the 3D Connexion driver (which is new as I have just bought one) it’s also the four built in extensions (the Sketchup supplied ones) that stopped loading a few weeks ago. The four Sketchup ones were loading without errors but something must have changed to stop that, I’m assuming a Sketchup or Windows update? I’d like to find the problem rather than take the nuclear option of reinstalling Windows - which always comes with its own set of problems with drivers.

I’ve done a full uninstall and re-install many times and still the four Sketchup extensions won’t load.

Is there a possibility that the .rbs file extension handler has somehow changed and Sketchup is using the default which does not now get interpreted by the Ruby interpreter? Or a system path that’s pointing to folders in the wrong order? Or an incorrect environment variable?

It’s just that I installed VS Code around the time it stopped working and I’m wondering if this might be the cause?

Any ideas anyone?