2016 Installation Fails to Run

Just got the email to upgrade to 2016 so I did. It downloads and was put in applications…

I run ElCapitan on a MacPro Tower 2 x 2.4 GHz Quad-Core Intel Xeon.

However, opening the 2016 SU folder, the app has the dreaded “no go” circle and slash.

Trying to open it, I get “You can’t open the application “SketchUp” because PowerPC applications are no longer supported.”

That is quite strange! I’m pretty sure the SketchUp 2016 app does not include a PowerPC version (certainly the copy I downloaded does not - I checked).

Mac Pro is certainly not PowerPC, and El Capitan wouldn’t work on PowerPC either.

Each version of SketchUp has its own folder. Any chance you’re in the wrong SketchUp folder?

Yeah, I thought of that too (I’ve been known to do those things)… However, look at this screen shot. You can see the dreaded circle & slash in the 2016 folder:

Screen Shot 2015-11-18 at 5.28.15 PM.pdf (73.3 KB)

I’m NOT saying’ this isn’t my fault (yet)

Did you download from the official Trimble site? I can’t explain what happened, but I’d suggest deleting the app and the installer, downloading again, and installing again.

do you have an old file association or plist to a previous version…

I still keep SU v5 around and recall an issue years ago…

it probably needs to be that old to cause an issue, i.e. pre-Google versions…

john

I’ll try that. I dnloaded it from the email from SU email: sketchup-noreply@sketchup.com

That is odd because SketchUp is not a PowerPC application (at last not since SketchUp 5 or so). Please try uninstalling and reinstalling SketchUp.

  1. Uninstall SketchUp Pro by visiting our Uninstallation Instructions at help.sketchup.com/en/article/36209
  2. After uninstalling, we suggest repairing disk permissions:
    a. Restart your computer.
    b. Open a Finder window.
    c. Click Applications.
    d. Click Utilities.
    e. Double-click Disk Utility.
    f. Select your hard drive.
    g. Select the First Aid tab.
    h. Click Repair Disk Permissions.
    i. Repeat step “h” until there are no more permissions errors that have been corrected.
  3. Log in to your computer with a user account that has administrative privileges.
  4. Please visit our SketchUp Pro page at http://www.sketchup.com/download/sketchup-pro-current to download the SketchUp Pro install file.
  5. When the download completes, double-click on the install file and follow the on-screen instructions.
1 Like

Footnote: the repair permissions operation went away in Disk Utility for OS X 10.11 due to the introduction of System Integrity Protection (SIP). Supposedly this operation is no longer needed because nothing can change the permissions on the protected areas - not even a root user. There is a workaround for very advanced users, but it should not be necessary in general.

It seems more likely to me that the download was somehow damaged in transit in a way that makes OS X unable to determine the file type correctly.

@jerryc are you comfortable with using the Mac Terminal window? If so, I can tell you how to check whether the OS really thinks that Layout is a PowerPC application.

I am comfortable but it won’t be necessary.

I uninstalled the 2016 app and re-dnloaded a fresh copy. That installation came in OK.

Very strange but I assume your hypothesis is correct.

Thanks for following up.

Jerry

I had the same issue here. Installed SketchUp 2016 on OSX 10.11.3 and found that the app is being shown as a PowerPC app. Uninstalling and downloading Sketchup again made no difference. What I have noticed is that SketchUp only appears to have this issue when inside the SketchUp 2016 Folder. If you move the SketchUp App outside the SketchUp 2016 Folder, OSX no longer sees SketchUp as a PowerPC App. That might be a quick workaround if anyone has this issue.

@mike_carlos_george, have you tried putting it back in it’s folder?

once osx has run it once, it should never revert to the error state and you’ll avoid any complications of not using the designated folder…

john

As was confirmed, elsewhere, SU 2016 refuses to run until you remove it from its install folder. Then the app will start. Move it back into the folder and - repeat - it won’t run.

I just ran the install on Mac under OSX El Capitan and I too am getting the PowerPC SketchUp Make executable issue. Note that the other two images in the installed Sketchup2016 folder do not show the circle-and-slash. It is 2016-02-22 and this is still an issue. I am hoping that a rebuild of the executable image and install package can be attempted by Trimble. It is pretty obvious that the problem is not on the user side. I am looking forward to the new version. Thanks!

I have a fix that does not require moving SketchUp Make 2016:

Open the Applications folder and the SketchUp 2016 folder within it.
Select SketchUp Make and, from the right-button-menu, select Open Package Contents.
Open the Contents folder and then the MacOs folder.
Double click SketchUp which will launch it in a console window.

SketchUp Make will run this way. Once it has started you can close it and run it the conventional way. You can also close the Console window after you close SketchUp.

Hope this helps. If you see an error in the instructions, let me know and I will confirm and update them.

I went into the package contents because clearly, based on the posts above, the executable image is not PowerPC code and therefore the problem lies in the application package. Unfortunately, I don’t know enough to spot the problem but I am sure the folks back at Trimble can straighten it out. In the meantime this is an easy way to make it work.

from your steps it would appear that you have/had a ‘PowerPC’ version of SU installed…

if so Right Click any skp >> Get Info >> Open With >> [browse to SU v16] >> Apply to All…

should achieve the same result…

by opening via ‘Terminal.app’ all you are doing is ‘Resetting’ ‘Open With’…

john

I just downloaded and installed the update to 2016 version and when running SketchUp Make on my iMac running El Capitan I receive the message saying is was not able to run the PowerPC application. I had following the recommendation and replaced my existing version. I’m now without SketchUp. :frowning2:
Thanks in advance for any help!

Did you try the things suggested in earlier posts in this topic?

Per your suggestion I did and it is now working. Thank You!

This problem recently reappeared for us here in our QA lab which allowed us to investigate in more detail and come up with a solution. Our findings and solution are laid out here: