Power PC error message on MacBook Pro

I have been using SketchUp on my MacBook Pro and it has been working fine. I downloaded SU2016 and when I attempt to run the program, it dies with the message You can’t open the application “SketchUp” because PowerPC applications are no longer supported. I have searched this site and can find nothing to help me. I did the repair permissons trick and also cleared the preference files in ~/Library as suggested, but no joy. I cleaned all remnants of the earlier Sketchup version, as well.

Any help is greatly appreciated…TIA

did you look at this thread?


DUHHH…I searched for Power PC, not PowerPC when I want a’lookin’. Thanks for the link. Looks like it may help me.

I don’t know if there has ever existed a SketchUp version for PowerPC Macs (or MacOS 9 or older).


Anssi…I believe the message is generated by OS X when it interprets the application as requiring PowerPC. I’m still working on it. Thanks!

how, exactly, have you installed v16?

when you double clicked the dmg from the download, did you drag the SU folder over the Applications folder that are both shown in the same window?

maybe a screenshot of SU in Finder would help us…


We had something we worked on in SketchUp 8, where one of our extensions (Advanced Camera Tools) was causing some of this. I’d check your extensions, make sure they’re cleaned out, (both **/Library/**Application Support/SketchUp 2016/plugins and ~/Library/… ), and see if that helps. At least that’d be my first guess, because plugins whold happen on load.

Yes, I did the drag-n-drop in the window when the .dmg file I’d double clicked. This produced the folder and sub folders in ~/Applications as always.

I have removed every vestige of Sketchup of all versions I could find, ran AppDelete on SU2016, and started with as clean a slate as I could manage. The screen shots following describe what I have now.

This is the state of the dmg as downloaded:

This is the status of the SU folder in Applications immediately after the drag/drop of the dmg into Applications. Note that before I attempted to run the app, it already has a circled-slash overlaid on the icon.

Finally, this is the message that shows after trying to run the app:

I am well and truly befuddled (and I have been using Macs since the Apple ][). More ideas/suggestions are welcome. TIA

this may be totally off the mark but…

the dmg is designed to be used in ‘Icon View’ and although it ‘shouldn’t’ make an iota of difference that your using the ‘Icons in List View’, other people seeing the same issue where as well…

failing that you could try the ‘bump start’ method from Terminal.app by copy/paste >> return

/Applications/SketchUp\ 2016/SketchUp.app/Contents/MacOS/SketchUp

if it runs from there, after quitting, it may start as designed…


If the App has a slash through it, it wont work. Why do you even try? Delete it, reinstall - your installation is invalid. Reinstall. If it still has a slash, your dmg is invalid. Download again.


Using icon view didn’t work the first time. I then used your “bump start” method and it worked like a charm. It now also works from both icon and list views. Thank you very much for the help. The following screen shot shows a couple of errors that popped up when I ran the shell command:

Now to get back to work!

If you read the thread you would have seen that I tried everything you suggested…no joy. As you’ll see above, John…'s suggestion worked like a charm. Since he indicates that others are having the same problem, I do not believe the issue was with my configuration. Perhaps the error messages I passed along well help others.

Those messages happen every time SketchUp is launched on Mac, but they usually go to the system logs so one doesn’t see them on the GUI.

Yes, that makes sense, as after the command line start, they don’t appear in the GUI. Thanks!

@john_drivenupthewall, who has to run SketchUp from the command line first time? I’m concerned @boatanchors has a corrupt download. @boatanchors, did you download Pro or Make, and when you do cmd-i in finder, where does it say the .dmg came from?

@Barry, this was a solution posted on the other thread, I’m surprised it worked then and now…

based on other reports I don’t think it’s corrupted downloads, it seems more like a incorrect flag is being set during the install…


I did some web searching, and SketchUp isn’t the only app whose users are reporting this problem. It seems there are some circumstances in which OS X can get confused during installation about the architecture of a perfectly valid 64-bit Intel app. So far as I could find, nobody knows exactly what goes wrong or why.

Another fix seen in forums for other apps is to copy the app onto the desktop, run it from there (which somehow avoids the PowerPC issue) and then copy it back to the proper folder. Some people also reported that changing the extension to something other than .app and then changing it back worked.

1 Like

Not likely a corrupt download as i downloaded it several times at widely differing times and got the same result each time. Here is the Info pane for the dmg file:

On further reading, both the problem and all of the fixes are consistent with the Launch Services database somehow getting an incorrect architecture entry for SketchUp. This database is automatically updated when certain things happen that make the system aware of a new application - for example, copying it into the Applications folder (as happens when you install), running it from somewhere else that the launch service doesn’t normally scan, changing it into something other than a .app and then back again, etc. OS X is also supposed to scan /Applications and update the database when the system boots, though it might not do anything unless it appears the app has been changed.