Mac OS X 10.11.6, SketchUp Make 2017 Crashes Immediately when Start Using SketchUp is clicked



This issue started as soon as I “upgraded” from 2016 to 2017 versions of SketchUp. I had opened SketchUp Make 2016, received a popup that a new version was available. I clicked the button to get the new version on the popup and the install seemed to go fine. As soon as I opened the new version (having already deleted the old version, my mistake) Bugsplat fired up immediately, though there was no window, just the icon in the Dock. I figured I’d see a window with a stack dump of some kind.

I had originally downloaded and installed SetUp Pro 2016 and the 30-day trial had expired, where I was just using SketchUp Make.

Other Attempts
I tried uninstalling SketchUp Make 2017 and trying again, with the same kind of failure. I then followed SketchUp’s instructions on how to completely remove all traces of SketchUp from my Mac, rebooting and trying to install again.

Now SketchUp Make 2017 at least gives me the Start screen and allows me to click the “Start Using SketchUp” button before crashing and Bugsplat starting immediately.


I have the same issue in Sierra, where it lets me select a template, then when I click the “Start using SketchUp” button it crashes and brings up bugSplat.

Could this be because Trimble thinks I want to use SketchUp Pro when I’m trying to run SketchUp Make?


how and where have you installed SU?

how are you launching it?

for the first 30 days Pro and Make are virtually identical, and then you will see messages about continuing to use either…

there is no benefit in any software ‘crashing’ itself deliberately, but installer bugs do happen and are usually fixed in a maintenance release…

are you attempting to run the latest version?




I installed SketchUp using the Mac OSX DMG installer downloaded from SketchUp’s site, after filling in my information.

I am launching SketchUp from LaunchPad or from Finder. Either way results in the same crash. Before installing 2017, I never saw this issue.


Let me also clarify by stating that I believe the issue is that I only have a graphics card with 256MB of VRAM. 2017 requires 512MB. It is slight annoying that the installer doesn’t check that BEFORE installing, as now I cannot get 2016 Make back as the pro version I can download and install states from the startup screen that my “License has Expired” and only gives me the option to install 2017.

Thanks for your help!



I’ve only got 256MB of ram and can’t even run Sierra on this machine but it runs SU v17 fine…

v17 is the only version that includes fixes for Sierra, so I’d be inclined to…

use to remove SU v17 completely

re-download the latest version [from the 18th of October]

open the DMG, drag the SU icon onto the Application folder icon

open it the first time clicking Finder >> Application >> SketchUp 2017 >>

it should show the welcome dialog…

if you get a Bug Splat, send it in with some identifiable info i.e. embeddedcrypticvapor and post the error code shown in safari, back here…

with a code someone can have a look for you…



I will try that. The issue I was also seeing is Bugsplat wasn’t showing anything. The icon would popup in the Dock but no window was showing.

I will try using AppCleaner.



I installed by mounting the .dmg file and dropping the folder into /Applications

Pro2016 is working fine. I should try Pro2017.

All Downloads were done yesterday so I would hope the Make2017 would have been the most recent version.



I tried installing again, then fully removed using AppCleaner, then rebooted and installed again. Same failure signature. BugsplatReporter is still not showing anything. Though I am getting these errors in Console:

12/5/16 10:50:23.449 AM SketchUp[504]: Error loading /Applications/SketchUp 2017/ dlopen(/Applications/SketchUp 2017/, 265): Library not loaded: @rpath/libifcplugin.dylib
Referenced from: /Applications/SketchUp 2017/
Reason: image not found

Looks like IfcImporter Plugin doesn’t have all it’s resources available?

Does SketchUp require Xcode?

I’ll send in a ticket.


@Barry might know a trick or two…



No, we don’t require Xcode.

So can you confirm that dylib is there? Type cmd-shift-g in Finder and paste in this:

/Applications/SketchUp 2017/

Is there a 12.1 MB dylib there?



Yes that file is there, but it is named slightly different than you show:

12M Nov 9 14:10 /Applications/SketchUp 2017/


Cleaned Console display and opened again trying to find other errors that may be causing my problem. I noticed these errors:

12/5/16 11:29:01.047 AM SketchUp Helper[842]: [11:29:01.040] VTSelectAndCreateVideoEncoderInstanceInternal signalled err=-12908 (err) (
Video encoder not available) at /Library/Caches/ line 1308

12/5/16 11:29:01.048 AM SketchUp Helper[842]: [11:29:01.047] VTCompressionSessionCreate signalled err=-12908 (err) (Could not select and open encoder instance) at /Library/Caches/ line 1003

I know SU requires Hardware Acceleration and special graphics support…maybe my Graphics is now finally old enough that it is no longer compatible with SU?

Do you all have a way I can simply reinstall SU Make 2016?


@Barry I notice that on the original error message, the dylib’s name is reported as all lower-case, libifcplugin.dylib, but in what the OP actually found (and what I also see on my Mac), the name is libIFCPlugin.dylib. If the system is set for case-sensitive file names, would that be enough to cause the load failure? I notice that the rest of the path uses mixed case names…


I am absolutely using a case-sensitive file system on Mac.

I reinstalled Make 2016 and it launches fine.


did you reformat your partition as case-sensitive?



Yup, saw the same thing. I don’t know - I’ll see if I can take one of our test machines and make it case-sensitive. Reading online, some programs, Adobe Creative Cloud for example, require case-insensitive (the default on Mac).


Not between installs, no. My partition has always been case sensitive.

Like I mentioned in the last update, having just reinstalled SU Make I can confirm 2016 works just fine.


OK, I confirmed the crash. Fastest way for me to get around it was to open SketchUp from Terminal and type:

open /Applications/SketchUp\ 2017/ --args DisableRubyAPI YES

I’ll see if renaming the dylib works (if there aren’t too many that cause this).



Perfect Barry, thank you. I’ll try that this evening after a reinstall.