SketchUp crashing without opening first

So my SketchUp won’t even open, it just shows me a bugsplat.
I have the 2021 mac version and haven’t been using this version for a long time (I had the 2017 version before). I’ve tried restarting my mac and opening the app in different ways and nothing seems to work.
I also have a few unfinished projects that need to be handed in for less than a week and I’ll have to do them all by hand if I don’t fix this somehow, so help would be VERY appreciated.

Edit: Just to mention, it was working perfectly fine the day before I wrote this.

the earliest releases had some problems.
Delete the folder of 2021 in the Applications, empty the Trash bin, restart the computer and download the latest version.

1 Like

The developers pay attention to bugsplats if you submit them. Include contact information so they can get back to you. If you copy the splat number here, that can also help get attention.

Let’s start at the beginning. Did you install SketchUp correctly? You should download the .dmg installer, open it, and when it shows a window with a SketchUp icon and an Applications Folder icon, drag the SketchUp icon onto the Applications Folder icon. Then close the installer window and eject the dmg. Do not try to launch SketchUp from the dmg itself.

Assuming that is ok, do you have extensions installed? If so, did you go to the Extension Warehouse and install the latest versions from there, or did you just copy them from the 2017 plugins folder? Try renaming the Plugins folder and restarting SketchUp. If the BugSplats cease, you have a bad installation of at least one extension. This is a risk if you copied them from 2017. Always start afresh to avoid such issues.

On Macs, those are the two most common causes of crash on launch. There are other possibilities that are less common. For example if you have formatted your system drive as case-sensitive. That’s not the default for Big Sur 11.6, so you or someone would have to have done it deliberately.


Thanks for the tips, however, everything that is listed above seems fine.
I submit bugsplats every time, SketchUp was installed correctly and the only extension I had was Vray which I deleted before I installed SketchUp 2021.

I don’t really know what that means but I didn’t change any of the macs defaults.

1 Like

Just did that. Sadly, it didn’t work. App still won’t even open, just shows bugsplat.

It’s weekend, so you probably won’t get any response from Trimble developers until Monday. Yeah, that kinda sucks…

So the current version you have of 2021 was working ok for a while, then spontaneously started bug splatting on open. Have you updated anything else on the computer? Graphics drivers, system update, security software?

I assume you have tried opening the app directly from the applications folder icon, without opening a specific file?

I understand the pressure. It’s a limited substitute but you could upload your working file to SketchUp Free online and work on it there, most of the same things can be accomplished.

Well, then I should get ahold of my pencil because the project I had halfway done needs to be handed in Tuesday lol :upside_down_face:

Hmm. Did it crash while you were working on a model? If so it might be trying to reopen that file and hitting a fatal issue again. If that’s the case, try renaming the file and see if SketchUp will open to a new file then.

1 Like

I did a system update, but I’m quite sure I did that before installing SketchUp.

Yes, from applications, launchpad and dock.

I don’t know why I didn’t think of that before, thank you. I will surely use it as an alternative till I figure this out.

1 Like

Nope. The first time it crashed the model opened but before I even started working on it, suddenly it just quit. From there the model didn’t even open at all just showed a bugsplat.

It doesn’t matter if you had edited the model yet. If SketchUp spontaneously crashed the model might still be at fault.

1 Like

I noticed that the last bugsplat you sent is was while running the earlier version of 2021. That suggests there may be a mixture of versions going on.

To make sure you’re trying the latest version, download the DMG again from here:

Go into Applications and delete the SketchUp 2021 folder. Then copy the new folder from the disk image. See if that makes things be more stable.


I just tried that, and the same happened like before. However, after trying to open it like 10-12 times it finally opened and looks ok so thank you.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.