Consistent Crashing 2019, 2020, 2021

I started with Sketchup 2021 and it worked fine for a few days. I was adding in dimensions and I went to change the text and the whole program crashed. Now, if I select more than one thing at at a time it crashes. After about 15 attempts (yes I sent the bugsplat reports) I decided to re-install. That did nothing. I updated my operating system to the new OS Big Sur, that didn’t do anything. I’ve now tried installing 2019, 2020 and 2021 (multiple times) they all keep crashing if I select multiple things. I have no clue what to do?

It’s really unfortunate.

Are you using some plugins?

None, just using the very basic functions. I also tried closing all other opened programs.

SU 2019 and 2020 are not officially supported on Big Sur. They may run ok, but it isn’t guaranteed and Trimble is not likely to do anything about problems with them. SU 2021 is supposed to be compatible, so since you have been submitting BugSplats the developers should take notice.

Thanks for your reply. I only updated to try to get the software to work. It was crashing on Catalina initially.

I just posted something in another topic. If you still have SketchUp 2021 installed, try what I describe here:

Hi Colin
ive been having crashing issues also but after i Updated and installed a few plugins yesterday. Ive tried all of the work arounds you’ve suggested even the terminal and it still crashes within 30secs of opening. I have the terminal text but it is too long to submit here. is there a way of showing you??


Ive had constant crashing since installing new plugins yesterday. Is there a way of fully removing them without sketchup being open. Also despite terminal address showing the location of the plugins, when i look only SkUP 18 and 19 are there???

You could look at the text, and if some of it looks like error messages, just quote those parts.

You can use the Finder’s Go menu, Go to Folder, and paste in this text:

~/Library/Application Support/SketchUp 2021/SketchUp/

When you Go there, rename the Plugins folder to something else, then open SketchUp. That will quickly tell you if the problem was one of the plugins. If it seems to be one of them, you have the plugins you tried in the renamed folder, and you can close SketchUp, move some over to the newly created Plugins folder, and open SketchUp. When it starts crashing again that means the extension you just moved back across may be the problem.

Hi Colin thanks for your reply.
the weird thing is that 21 doesn’t appear in the application support folder. I can access the plugins through the applications-package contents route. doesn’t seem to effect if i change the plugins folder name on that.
excerpts of the terminal below;
GVA error: Not detecting IGPU in IORegistry!

GVA error: Not detecting valid offline codec!

GVA info: Successfully connected to the Intel plugin, offline Gen6

/users/papag/library/application support/sketchup 2021/sketchup/plugins/sketchucation/!scfapitools.rbe:488: warning: deprecated Object#=~ is called on FalseClass; it always returns nil

dyld: lazy symbol binding failed: Symbol not found: ____chkstk_darwin
Referenced from: /Users/Papag/Library/Application Support/3skeng_V2021/Sketchup 2021/ext3skeng.bundle
Expected in: flat namespace

dyld: Symbol not found: ____chkstk_darwin
Referenced from: /Users/Papag/Library/Application Support/3skeng_V2021/Sketchup 2021/ext3skeng.bundle
Expected in: flat namespace

Abort trap: 6


Im in !!! managed to find the 21 folder and deleted the offending items. seems to be ok now thanks for the help

The significant change in 2021 was that Ruby 2.7 was added. If you have narrowed it down to certain extensions, check to see if those have been updated recently, to cope with the Ruby change.

Weirdly it seems as if it was the sketchucation free extensions and Artisan tools that was doing it.
thanks Again!