took too long to respond - can't log in - 1st time this has happened, I have internet

This is the first time this has happened to me and it is quite frustrating considering it is only a problem with the subscription service and not with the old faithful classic license that I was convinced to leave behind!

I have internet, and once a month, I log in and all is well, but something has changed and now it is saying that the site cannot be reached, and I cannot use my software that I pay for annually - which by the way costs considerably more these days after it was sold onto Google and then onto Trimble.

Hopefully there is an easy fix or else I can’t earn my income today and wont be able to afford to renew my license next time it comes around !

At the mercy of the internet is quite frankly over the top anti-piracy action, surely once a year would be sufficient ? I.e. when you pay for it, you get it for a year without internet !

I’ve deleted my cache / cookies etc… and restarted windows and still not working, is it something at this end or is there an issue at Trimble? I have read other topics and seen that some kind sole issues a classic license to ‘keep people going’ whilst it is sorted out - I would be very interested in this as I have a deadline coming up and I need to work on it asap - I don’t use the web app and I don’t think I want to resort to that as it hasn’t got all my plugins and shortcuts setup - even if that’s possible ?!

Please help !

Kindest regards,

2 hours later:
tried deleting cache in appdata/roaming/etc. etc. login_session.dat and also tried deleting shared preferences.json… deleted internet history/data/cookies, signed out of Trimble, restarted bla bla bla, it’s still not working and I’ve wasted two hours of my life and cant use a programme I’ve paid for - what a pain in the bum (putting it mildly)


what has changed, what am i doing wrong?! please help

A few weeks ago a person had the same problem, it was because his new router was blocking the sketchup website for some reason, can you check from your phone or any other device that isn’t connected to the same router if you can login into your Trimble account?

Also have you installed extensions to your web browser? Maybe an add blocker could be causing this.

1 Like

hummm, we have swapped our BT broadband router within the last 28days… so this is my next port of call … cheers for your replies and raising this as a potential culprit!

BTW, it’s only the sketchup programe that wont sign in… I have not got a problem signing into my trimble account on google or onto the forum or onto warehouse etc. it’s all working fine, i can use the web modeller (but i dont want to use it!)… / LOCALHOST is actually the address of your own computer and is often used so software can talk to a browser - if it is not loading it is usually because you have a setting or something somewhere blocking access to it.

This might be
A firewall
A privacy setting
An antivirus package

It can also be that the software doesn’t have the correct admin privileges to run the web service that talks to the browser

If any of these ring a bell, try disabling them and trying again.

thank you,

the only thing that has changed in the last month or so is changing our BT hub out for a new one. I’m not an expert with it, but I’ve gone onto the hub and temp disabled the firewall and tried again, but no joy.

I’m not sure what settings would be different out of the box from BT hub that would prevent this one web browser launch from working, when the rest of the internet is working etc… I’ve also tried temp disabling my antivirus and don’t have a VPN, so still at a loss… I suspect it must be the BT hub, and I will keep trying one thing at a time…

If anyone else has had this issue recently with a BT hub replacement then hopefully there’s a solution

Try reinstalling SketchUp - make sure to right click the installer and choose “run as admin”

You could also connect your computer to a phone using the WiFi hotspot mode and remove your new router from the equation. That will help you work out where to look next

I had already tried repair on a new download from my trimble login, I have also tried hot spotting my phone and still getting the same issue - the webpage says and it comes up with this site can’t be reached - took too long to respond…

thanks for all your help, I don’t know how to get it to work and i cant do any work, I’ve sat here for 4 hours going mad !

I must be getting old !

Edit: I ran the repair not the remove - I really don’t want to have to uninstall and loose all my plugins, preferences etc.etc. (not now, and certainly not every month ! lol)

it’s just this one splash screen - if it would just connect for like long enough for me to sign in and then it can go back to not working !! Ahhhhhh

Well at least you now know it’s not a router issue.

If you remove it and reinstall - your preferences and plugins should be retained- I don’t think those folders get deleted - but rather than do that you could try installing a different version of SketchUp , 2021/2022/2023 are all still supported and will all install independently.

That will help narrow down if it is the current SketchUp installation itself OR something else causing wider issues

I’m at the point of uninstalling and reinstalling…

Interestingly, I still have last years 2022 subscription / version installed during the upgrade period to 2023 a few months back and tried to login with this - and still get the same issue… so I’m at a point where I just need it working so going for the reinstall…!

Well that suggests it is not the software that has issue - rather an external force interfering.
This might sound obvious, but have you tried restarting the computer?

On your windows start menu, search for CMD and open a command prompt



What does it say?

I’ve just run windows network diagnostic, does this mean anything to anyone:

‘The remote computer isn’t responding to connections on port 61923, possibly due to firewall or security policy settings, or because it might be temporarily unavailable, Windows couldn’t fine any problems with the firewall on your computer’.

I cant tell if it’s my issue or an issue with the method sketchup use to do this 28day login check. If it’s something that’s happened with my new router, then should I contact BT for some help with the advanced settings ? Or should I try logining in again tomorrow ?! Should I take laptop to a friends house and use their WiFi ?!

Why does the signing in screen still have the ‘Add Classic License’ option when Sketchup stopped offering that as a purchase option in Nov 22…

I am going to bite bullet and do a complete remove and reinstall as I can’t afford to not be working on jobs for my clients!

C:\Users\AWHDS>ping 127.0.01

Pinging with 32 bytes of data:
Reply from bytes=32 time<1ms TTL=128
Reply from bytes=32 time<1ms TTL=128
Reply from bytes=32 time<1ms TTL=128
Reply from bytes=32 time<1ms TTL=128

Ping statistics for
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 0ms, Average = 0ms


yes I tried restarting computer many times during the morning…

Have you cold booted the Bt router.

Ok, so you can ping the standard port , but windows diagnostics can’t use the one it wants to use either.

What firewall / antivirus solution do you use?

I just did a restart and at the same time powered off the router and unplugged for a minute and fired it all back up and still same message… is that what you mean by cold booting ?

I’ve tried using the BT-WiFi hotspot and my phone and the internet works etc… it’s just this sign in screen that isn’t working… If i use a network cable and plug laptop in, will that be any different than using the Wi-Fi ?!

Just to clarify , did you connect your PC’s WiFi to the phone’s hotspot mode?

Hi, yes, i USB tethered my phone and used mobile data to hotspot, the laptop went onto internet with this connection and I tried the sketchup sign in and got same error / issue…

I have just tried clearing all cookies again and deleted that file in the user folder and tried again and it’s the same message ’ this site can’t be reached’ took too long to respond. . I’m taking laptop downstairs and plugging it in even though i don’t think this will work… i still haven’t reinstalled as I cant bring myself to do this yet…!

Edit: turned wi-fi off laptop, plugged into router with cable, and got internet access, and still not working/same message…

Given the symptoms , the things turned out and the message from windows network diagnostics , it must be something security software related.

Do you use bitdefender or AVG?

I have ESET (paid for 3 year subscription) and it hasn’t been an issue until now… And earlier, I did temporarily disable the firewall and the real time protection just to see…

I can’t get my head around why everything else internet related including this conversation is working, and it’s just the launcher related to the sign in screen… It usually only takes a second to log in and back on with the program launch and crack on with work…

Apologies if any of my comments have been aggressive or negative, I’m sure you know the feeling I’m having right now! Like Elliot when E.T. is sick lol! I appreciate all the help and comments from everyone.

I can’t see it ‘suddenly’ working so will probably do a fresh uninstall and reinstall this evening if all else fails… I really need to write today off and ensure it is working for tomorrow…

Perhaps check for an update to your browser. And that it’s not blocking pop ups.