License login issue

Hi All- I am trying to launch Sketchup and it is asking me to login to verify my subscription. It won’t launch the browser and I have tried everything to figure out if I can manually get to the login page myself with no luck. Any advice? The “help” email guys are slow to respond…

EDIT: I have read through a few previous threads and tried clearing my cache, deleting cookies, etc. Restarted my machine.

I am having the same issue.

Trimble connect website/ Trimble licensing is allowing me to sign in, but not SketchUp.

This happened yesterday and I was able to keep working for some reason ( i can launch sketchup and open existing files), now it has kicked me out again today.

OK, so I just got off the phone with the help desk (I take back my salty comment!) He said if you don’t have all your browser windows closed before you clear the cache, it won’t work properly. I had also uninstalled the program just before he called. So, the combo of reinstalling and clearing the cache with browser windows closed did it.

Can you please describe the process to clear your Cache?

(assuming you are on Windows 10?)


You do it through your browser- if you are using chrome, go the three dots in the top right, then settings, then security, then clear browsing data