Trimble Identity Frozen

Hello everyone,

As of lately, I’ve been completely unable to connect to Sketchup (i’m using the subscription version of Sketchup Shop), due to the loading page of Trimble Identity being frozen.
I’m not able to do anything on the page, can’t even try to log in or anyting, everything is just stuck.
I’ve already tried reaching out to their support but no one is responding, and I didn’t find any solution through my own research.
I can’t even access my account to cancel my subscription since it won’t let me log in at all, so i’m currently forced to pay for a product I can’t access.

Have you tried a different browser?

Yeah, I’ve tried Chrome, IE and Brave, and I get the same result on them all.

The thing is just stuck at this point, it seems to be trying to load, but I can’t figure out what’s freezing it

Pop up blockers, ad blockers, anti virus, firewall, vpn

Good call, it seems to be the vpn, i had not thought about that, Thank you !

Do you happen to know a way to work around that ?
I’m pretty sure I used to be able to access Sketchup with my vpn on before.

No sorry, no idea.

Well, thank you anyway, have a nice day !

Aside from the ad blocking issue where the log in fields don’t show, you have another issue. Your web page is stretched horizontally. Instead of seeing a blank log in area on the right, that is caused by the ad blocking problem, you see nothing. I think the log in things are off screen.

Try setting the zoom value to 100%.