Can't log in to trimble - can't open sketchup

Hi! I didn’t use My Shetchup por for about two weeks and a half due to holidays. No i want to start working again, Sketchup sends me to trimble to login as usual, but this time i do not have the possibility to enter my login and pasword, i just get a blank page. No errors, just blank.

How can i solve this?

I bought my license in November 2022, so it should be working fine for some more months…


Fairly simple solution,
turn off your VPN and/or adblocker, or at least whitelist the page.

and turn them back on. there is a cookie that you’re blocking IIRC

I tried, but I do not have a VPN or similar… It still doesn’t work :frowning:
Cookies were checked too, without succes.

Ive had this before. It was on safari - think i had to install chrome and make that default browser. Pain in the hoop all the loggin in…

It looks like something related with your browser or internet connection, have you tried using a different browser?

@francisquitof: I tried every possible browser, unfortunately still doesn’t work…

@barry1; indeed, the constant loggin in is very annoying!

Feel very frustrated… wanted to continue my projects, but can’t even schedule meetings with my clients, as i can’t show/enhance anything.

Can you open an incognito tab and enter

No, i get this error:
{“message”:“Missing Authentication Token”}

And this one:
Sign in in the top left

So sorry, just tried it.

I click on Trimble, but the only thing that happens, is the ‘sign in’ sign at the right jumps up. When I try to login that way, I have the same empty screen of yesterday…

Have you tried with another pc or with your phone?


yes i tried with my phone, just to log in on Trimble and that worked! I could see my profile and i had the chance to create a recovery mail. But I still cant’ login to sketchup on my laptop…

You said you don’t have VPN, but do you have any ad blockers? Those are what usually cause the right side of the page to be blank. How about a firewall, are you using one of those?

We found the problem! Recently we bought a new router (UniFi) Somehow this router is blocking me. I now created a hotspot on my phone and my menu is back!

Anyone here who knows which setting on the router we have to change?

Thanks all for your help and sympathy.

If you can, set the router to allow and

I’m having trouble opening the file in the Dropbox link below in Sketchup 2023 Can you help?

Double posting creates confusion. Please don’t do that. I’m working on your file now.