Just can't login into Sketchup Pro 2019

I just can’t login into Sketchup Pro 2019. I choose to login at the welcome screen. It opens Trimble login page, I use then my credentials and then it seems to redirect to a localhost that it’s not working, so it doesn’t gives the token back to the software. Please, help me out!

Hi @sbarino, can you share a screen shot of what you see after you click login?

We have a support case from sbarino. He is getting an error that we’ve only seen in IE and Edge so far. The possible work around is to edit the start of the url to change it from 127.0.0.1:55795/ to be localhost:55795/ instead.

Hi @colin, I’ve already tried to change it to “localhost” but it didn’t work either unf.

Hi @niraj.poudel.

This is what is showing after I login to Trimble account. This is using Chrome, but it is also happening with Edge.

Sketchup calls this URL with different ports everytime. None of them is working.

Being different ports its normal. I read about one issue where adding / to the end of the URL would work around a problem, could be worth a try. I’m looking into other ideas.

Do you have access to any other computers, to prove that it should work? Like, install SketchUp and try signing in on that other machine.

No, unf adding / to the end didn’t work. I’ve also tried adding http:// and https:// to the beggining and also tried removing the port info to the address. Nothing of these worked. Is it possible to the support team to have remote access to my computer to try to figure it out? Unf I don’t have other computer with me right know as I’m travelling to work in a project abroad (I should be finishing my work by now if I could install Sketchup).

I have sent you remote connect instructions in reply to your support email.

Here is the first thing I will check if we do connect. If you use a proxy server there is an option to not use that server for local connections. Hopefully that would fix localhost as well as Intranet addresses.

For people following along, we did do a screen share, and the usual issues don’t seem to be the case this time. I will need to talk to the developer who does this code on Tuesday.

For now I put in a Classic license, and that works fine. For using 3D Warehouse or Extension Warehouse, those can be done in a browser until the problem is fixed.