Zooming in LayOut eats RAM

unknown

Hi all. Sketchup Pro user here

I often zoom in in LayOut to try and get my dimensions on the right vertexes, however I have been running into an issue where LayOut hangs and eventually crashes when zooming in, using preposterous amounts of RAM along the way - 64GB or more!

I work daily in Sketchup and this happens independently of the complexity of the model

I have been hoping for this bug to be fixed for a while now, and have upgraded through 2019, 2020 and now 2021 hoping each time that the issue would disappear - but to no avail.

Any workarounds or solutions would be appreciated

There is a different issue to do with how long it takes for page thumbnails to be made. You could be seeing that, and it’s not related to the amount of zooming. For the thumbnail issue you would want to wait it out, and then do a save after the thumbnails are made. They will be saved and loaded quickly next time.

Could you say something about the amount of text there is on the page, and in the areas you zoom in and out of in particular?

Hi Colin. I can say at least that there is no on screen notification about thumbnails as one might see in SketchUp.
The issue is clearly correlated with zooming - as in, I zoom in, and as it zooms closer and closer the performance of LayOut gets worse and worse until the computer hangs for minutes at a time, or crashes, this is usually with a single act of scrolling the mouse wheel, if I accidentally zoom too far I’m done for.

There is text on the page, although not great deals of it - 100% of the time I’m working on a template with our drawing border which is a placed PDF, overlaid with text elements such as Scale, date etc.

Untitled.layout (131.6 KB)

Your footer and background is made up from a PDF, and at life size it’s 420x297mm, but when zoomed in it gets to be 6300x4455, which is 225 times as demanding. That could be improved a lot if only the footer was a PDF, of around 420x30mm. Better still, if it was made from individual elements, the amount of screen area they would cover would be a lot less than a PDF.

I wish LayOut could import SVG, with colors, then it would be easy to create the red logo and the black footer text. Another way to get the effect is to use a SketchUp file, set to vector, and locked, with auto render turned off.

Try this file to see what I mean about the performance improvement.

rollercoaster2017.layout (2.5 MB)

1 Like

Whatever the particular issues here, I also find that zooming in LO is nowhere near as smooth as it is in SU. It is so easy to zoom in too far or back away too far. Often, for no apparent reason, most of the image disappears almost off screen at the bottom.

Wow, thanks Colin thats a huge improvement.

Good instincts about where the problem might lie as well - as soon as you started asking about the document I suspected you were on the right track for a solution!
We have been using this template (or variants of it) for a long time now, and the zoom issue was not always present in older versions of LayOut

However I’m happy we have a viable solution going forward - I’ll put in a bit of time to continue to develop what you have there.

Thanks!

1 Like

Colin, what did you use to convert the PDF to a DXF?

Adobe Illustrator. But then I took the DXF into SketchUp, to make what you now see on the page.

You could continue to use PDFs if you have a way to make those. Just make sure it’s only as tall as the footer area.

Thanks. I tried that - even with the size reduced it still makes a big dent in performance leading to crashes when I use a PDF there unfortunately

The issue I am having now is that when I send my SKP to that template, the model replaces the footer rather than coming in separately?

Rhino import PDF as vectors, so you can export to what you want.

I had exactly the same issue…

I think I would rarely use the send option. If you use File, Insert instead, does that behave itself? If you need additional viewports of the same model in the same LayOut file, make the new one by doing a copy and paste.