Layout 2020 keeps freezing requiring reboot

LAYOUT 2020 keeps freezing, I only do small models (architecture) however after about 20mins, I have to hope to save it then completely reboot?

Can you share the file?

Mike
all works well until I start adding some line work/dims, and if I scroll while doing anything just freezes, Im on Mac ( latest updates)REED PLANNING.layout (14.7 MB)

I’m having similar troubles with Layout 2020. Text, dimensions and linework all lag when I try to reposition. What’s weird is when I relocate the anchor (on text, for example) it seems to smooth out somewhat. Running Sketchup / Layout 2020 on the same macbook pro that I have been running 2019 on - with no problems whatsoever.

There is something on the page block 1: 500 that is a great distance from the left side of the model. Could you also share the .skp file

I have several Layout template models, I have tried the same sequence on all, all with the same result it freezes, do some dimensioning, try a few lines scroll in and out ? “then chill time”

I’m also having this issue on my new iMac. Dimensions, text, relocating/resizing text boxes, viewports, etc. all hang up. In fact, most of the time I’ll move something and nothing visibly happens - though the task has been executed and can only be seen if the scroll wheel is moved.

Did you find a solution?

Thanks

Well, I’ve had the LO file open for about 20 minutes and I’ve scrolled about and added dimensions, text and lines, opened up the SU model from LO and it hasn’t crashed.

A few observations…

At first glance the SU model seems rather large for what it is and Solid Inspector (a plugin) brings up many stray lines, internal and external faces, etc.

I’m currently working on a dormer conversion with lots of structural detail and it’s a quarter of the size of your model.

@RLGL - I can’t find the something at great distance on the block 1:500 page…

Agreed. I ran CleanUp3 on the .skp file and got this:
Screenshot - 2_19_2020 , 5_55_47 PM

I’ve been playing with the LayOut file for awhile and had no real problems with performance. It improved a little after cleaning up. the worst zooming performance was found on the page with the photos of the house but those images are quite large. I reduced them to 2000 px wide which helped to improve zooming speed on that page noticeably and they still look fine. I exported a PDF of that page at Medium quality. REED PLANNING.pdf (3.6 MB)

After purging unneeded and straf stuff from the .skp file, reducing the size of the images on the last page and purging unused stuff from the LO file, I got the LayOut file size down by about 20%.

@RLGL, just FWIW, the .skp file is embedded in the LayOut file so no need to have it uploaded separately.

My solution was to revert to 2019. Smooth as silk (same MacBook Pro). Don’t forget to unlink / relink your references after you’ve done the save as to 2019…
Hopefully they’ll figure out what happened and update 2020.

Following! I am having the same issue with 2020. My work has come to a halt until I can figure this out.

Paul, as an update, now upgraded 2020, got a new tMac and software, the attached file is Layout only, there is no sketchup, This is a generic template from Layout, nothing other than title block on it, yet when I scroll in and out or add something then scroll, freezes? any thoughts, 05-05-2020.layout (16.6 KB)

It seems many have issues with SU/LO on macs (I’m on PC).

It’s beyond me why a generic template is causing your problems.
Others with more diagnostic experience may have some ideas.

Seems graphic cards can be a cause of issues.

Sorry I can’t help :slightly_frowning_face:

1 Like

Adding this link here too, it may help:

Hey, I’m having the same “g.d.” problem!
2020 is acting very strangely.
When I try to move text - It lags, or doesn’t move -
There’s “like” a delay.
If I scroll the mouse,… it moves (hard to explain)
WTF Eh? Sorry, no answers from me.

Forget the scroll , move the zoom tools up onto pallet, works for me