Zoom speed adjustment?

Can anybody tell me -

  1. Where are the shortcut keys to adjjust Camera Zoom in and Zoom Out?

I dont see them here. Has the option been removed in 2021?

  1. Is it possible to adjust the amount of zooming that is performed by the scrollwheel. I dont see any sensitivity adjustments within Sketchup.
    Adjusting my mouse (logitech) ussing Windows settings doens’t change SketchUp’s zooming behaviour (scrollwheel).
    I do have Advanced Camera Tools, but that doesn’t help.

What I 'd like to acheive is for SketchUp to zoom in at a much slower speed (finer increments). This will require me to scroll the mousewheel (or pushing keys) for much longer, but it will greatly smooth out the experience for people watching my screen.

An adjustment for Zoom Speed? There’s never been an adjustment for that In SketchUp. There is in LayOut, but not SketchUp. In LayOut it is referred to as Scroll Speed.
Screenshot - 11_4_2021 , 4_26_29 PM

In SketchUp the zoom speed is determined by what your mouse is pointing at, as the movement always happens in relation to the selected 3D point. Pointing at a nearby face or object zooms much faster than when you point at empty space=infinity.

1 Like

Yes I realise Zoom Speed hasnt ever been adjustable (like Scroll Speed), but I thought (based on other forum threads on this subject) that zoom was available via a shortcut key.

You would set the zoom speed in your mouse settings for scrolling, if scroll speed has any impact on zooming. I’ll have to look into this.

On windows Anton’s Smooth Zoom might help you out.

True, and I understand that already, but there is still a default zoom distance; which should be able to be adjusted …somehow.

Tried that and got some issues with the AMS Library - seemed to cause unstability in SketchUp so I unstalled it.
It’s a good concept and works reasonably well but I was hoing for a simpler and more “factory-setting” style solution.

Some mouses (including mine) even have software to switch Profiles (pointer, button and wheel settings), but these didnt seem to apply to SketchUp zoom for some reason.

Never had any myself.

Did you try lowering the scrolling speed of the mouse?

Yep (of course) and it makes no difference.

I think the zoom setting is something to do with the graphics redraw timing rather than scrollwheel, but it just happens to use a scrollwheel-like behaviour (stepped motion). Odd, since Orbit is smooth, and the Zoom tool on it’s own is smooth when applied using the left-mouse-click.

I’m currently playing around with the Trackpad (for zooming in/out) and the mouse (for orbiting) together, and using the new version of Smooth Zoom.

Also odd is the fact that there doesn’t seem to be a Pan left/Pan Right tool - just “pan” which is a hand-grabby thing.

I reckon this has to be a feature for SketchUp 2022…