Mouse Wheel Zooming Too Sensitive


#1

Hi! I just upgraded to SKP 2017. I have this weird problem with the scroll button. Whenever I zoom in or zoom out using the scroll button, skp automatically either zooms in very close and stops or zooms very far away and stops. I wish I could show a video to show this problem. I always use the scroll button when panning/zooming and this is becoming a burden for me because skp 2017 seems to have the zoom function too sensitive. I tried to compare it with skp 2016 and I had no problems with the older skp because it only zooms in or out when I operate the scroll button. Does someone know how to change it? I really like skp 2017 but the zoom function makes me avoid using it. Please do inform me what to do. Thanks!


#2

What is the scroll button? It may be a Windows thing I don’t know about.

I’m guessing you’re on Windows by the way, in your profile you have Intel Core i7 as your operating system. I too am using Intel Core i7, but inside a Mac. Are you using Windows7, 8, 10, etc?


#3

I am having the same problem. The scroll doesn’t match the scroll on the mouse, one small scroll in on the mouse zooms in very far on SketchUp. Any way to change this?


#4

I see this topic came up a few years ago. Perhaps some of the same suggestions will help for this time?

http://sketchucation.com/forums/viewtopic.php?f=11&t=53308


#5

I am using intel core i7 on a Windows 10 Operating System. What I meant about the scroll button is the scroll wheel of my mouse. I use it every time for panning and zooming because it’s a lot faster to do models with it than pressing Z on my keyboard. Now my workflow and modelling time is being affected by the zoom function in skp 2017. I haven’t encountered this problem yet in any version of sketchup even though I’m using windows 10. The problem only occurred when I upgraded to skp 2017. I have already read the link you gave but the problem is, I’m not using a Logitech Mouse. How do I change it? Is it an SKP problem?


#6

Do you still have an older version installed too? One test you could do is to start a new file in 2016 and in 2017, and mouse wheel in on the body of the featured SketchUp team member. Both should zoom at the same speed. If they do that would suggest a specific SKP file has an issue,and you could try saving the suspect file as 2016 and trying it in the 2016 version. If the SKP you’re trying works fine in 2016 but not in 2017 (same if the two team member bodies zoom at different speeds), check the various preference settings, to see if there are any differences.


#7

Yes I’ve already tried those. All the possible steps. Even tweaking the existing options in the preferences. I thought there was a zoom factor setting in the preferences but there is none. Thank you for your advice my friend! I’ll try to see more possible solutions regarding my problem.


#8

It’s strange that you are seeing a difference in zoom speed. I’m not seeing any difference between versions on any of the three different Windows machines or the Mac I have running SketchUp. They seem to run the same for me. Have you compared the same SKP file between the two versions?


#9

Yes, I did. I tried it with the same models and I also tried it without models


#10

What was the outcome of the test with a new document, did the 2017 version zoom into Chris differently than the 2016 version zoomed into Lisanne?


#11

Yes. The skp 2017 still is too senstive even with a new document while for skp 2016, it is still normal


#12

Can this be tied to high-DPI case? What is your windows scaling?


#13

Is that the screen resolution? Mine is 1600x900


#14

That pixel resolution in probably not a high-DPI. That is at least not the reason then…


#15

If there was a reason that HiDPI did affect the mousewheel speed, you would expect it to just double or halve the speed. The description we’re getting is that the zoom lurches forward at great speed.

I gave it a try under Parallels, but unfortunately Parallels still doesn’t use OpenGL 3, and so SketchUp 2017 won’t run.


#16

Not necessarily.

Windows can scale odd figures such as 175% or high as 300%.

On the other hand, I always suspected if this would effect the scroll speed:

Although I don’t think it does.


#17

Whatever the Windows settings, surely someone testing between 2016 and 2017 would leave those settings alone? Also, those settings refer to lines and characters of text, presumably SketchUp is doing its own reading of the mousewheel?


#18

Hey, i’ve noticed something similar but it only happens after i’ve had sketchup opened for a while.
by now i think ive seen this maybe 5 times. When i use the mouse wheel to zoom in or out it just goes wayyy past where it should go.
in my case, i’ve been able to just close the file and open it again. That has solved the problem for me. It seems that in your case the problem happens always

my recommendation is that you uninstall SU and install it again, as that should not be happening

hope it helps


#19

Hi there
Been reading your post regarding mouse scrolling sensitivity.

I too have this problem and just started looking for answers.

I’ve read all the posts and am wondering how you have gone sorting this out?

I use Windows 7 on a laptop but I also use a Logitech Mouse from the Logitech Wave series keyboard/mouse combo.

I have been curious as to which type of mouse you have using?

Thanks for any feedback.

Cheers


#20

i have same problem It is very uncomfortabl. now in 2017 zooming with mouse wheel is really bad. if someone know how solve it pls feedback