My mouse wheel doesn't zoom in and out

Hi All,
I’m using Sketchup make and my OS is Windows 8.1. My mouse is wireless Logitech. I can perfectly orbit and pan using my wheel but not zooming in and out at all. It’s really bothering me when I’m working and I have to go back and forth to the toolbar to zoom in and out. Is anyone able to instruct me to assign the wheel to zoom task? Thank you.

There is no setting for this in SketchUp itself, it depends on the way the mouse driver communicates the wheel events. Does the wheel cause windows in other apps to scroll? If not, check the mouse settings to verify that the wheel is set for scrolling. If so, then I am lost…

thanks for your reply. the mouse doesn’t scroll anywhere! how can I change the setting? I couldn’t find any option in my mouse setting.

I’ve just checked my mouse setting at the control panel. it’s set to work but it doesn’t do anything when I role it!

Sounds like there could be a problem with the mouse itself. The click action you use for orbit and pan is a separate switch inside the mouse from the wheel rotation sensor, so it is possible for one to work while the other fails.

okay, thanks for your detail response. I’ll check another mouse and will see how it goes. at least I learned the problem is not from my software. thanks.

It sounds to me as if the mouse encoder wheel has failed but you might try replacing the battery first. I’ve had flaky response from my wireless mice when the batteries are getting low.

Another possibility is that you have disabled, or assigned different function to your scroll wheel.
Only if you have installed the SetPoint for the Logitech mouse and have tweaked its settings. but, might worth checking that out.

Question there what kind of a mouse should I be using on my laptop . . to get the measurements right seems my finger is just not haha a good adjustment for getting the edge of a circle or a rectangle the right size . .

I have had this happen, in the past. I ended up rebooting and everything worked (probably an OS or mouse driver issue that was fixed by restarting).

My zoom is fading, intermittently, both with the mouse wheel and the screen button. Weird . . .

What do you mean by “fading”?

Sorry. I mean that it’s cutting in and out, randomly. The effect is identical whether I’m dragging the icon or using my scroll wheel. Sometimes it will move very slowly, other times not at all. After a couple of minutes, while working around the issue, zoom returns to normal. This just started this afternoon . . .

Sounds like maybe a graphics card driver. Have you had a recent driver update? What kind of graphics card?

I’m using a Mac running Mavericks (OS 10.9.5) – I don’t know about the graphics card. (Don’t hit me – I’m old !)
Just starting to use Make. So far so good – but today I’m adding stuff to a portion of the model after hiding and locking and opening it a couple of times. I wonder if I did something wrong there – I’ve done what I could to read up, watch the starter videos, etc. Beside the zoom issue, I’m have random reassignment of color (blue and white), parts disappearing while fixing something else – having trouble filling in rectangles consistently, and don’t know how to fill a rectangle with a wedge cut from it. The same moves work one time and not the next. Whew.

To be specific, my mini is late 2012, has an Intel HD Graphics 4000 1024 MB, 2.5 GHz Intel Core i5, 4 GB of memory 1600 MHz DDR3. Should I need an external graphics card ? I don’t plan on rendering beyond what SketchUp provides (Make for now, maybe Pro later . . .) I like what SketchUp can do, and the look of the output product (very thoughtful graphic design), and I’m having a ball after a lifetime of pencil drawing.

Thanks for your advice. Steve

Hi,

There is room for improvement in terms of upgrading your computer system to a high(er) performance machine.

BUT, I suspect that you probably have enough computer to do the work you want to do. What’s missing is a little familiarity with some of SketchUp’s quarks.



RE: Zooming. . . Try to pay close attention to what’s underneath your cursor while you zoom. Attempting to zoom over empty space will give you dramatically different results than when zooming directly over part of your model.

SketchUp gets tricked up trying to determine what level of zoom speed it will apply over empty space. When zooming over the model things work a lot more smoothly. At larger distances, zooming speeds go fast—but as you get closer to your model the zoom speed ramps down to prevent going straight through it. . . at least right away.

You absolutely can zoom directly through an object, and during that time SU’s zoom speed will be at it’s all time slowest speed… it’s just the slow speed compounding from ‘the slowing down as you get closer’ design of the zoom tool.

. . . Sometimes what’s behind you has a big effect as well. This is a ‘real’ 3D environment as it were, and it is possible to backup so far that you bump into an opposite wall, or some other nearby object (which you can’t see)… and the close proximation of smacking your butt (there are better words here) on the hidden object results in the change of zoom speed once again.

Use the Orbit, and Pan tool, along with the zoom tool so that you can rotate or tweak your viewpoint in an effort to avoid some of the zoom issues.



You’re probably looking at the old classic reversible face here. Where white is the front side of the face, and the bluish gray is the back side of the same face.

There’s a command called ‘Reverse Faces’ that you can use to fix this sort of thing.

. . . and technically you should have the Front (White Side) facing out. . . although this isn’t always going to really haunt you.

It can cause issues with applying materials to your model. Materials only apply to a singe face (front or back… but not both).

It will mess up your model when exporting to other file formats, or to 3d printers.

You could be hiding them, or accidentally deleting them.

Coplanar Issues ?? join the club.

If your not experiencing faces being generated automatically, then your probably not drawing your raw geometry as a single plane. SketchUp is designed to automatically fill in face whenever the edges combine to create closed loop on a single plane.

This can also happen by not closing your edges. SO off-plane shapes, or unclosed loops, are both going to end up with SU not drawing in the face.

Zoom in close on your geometry, and orbit a bit to see if your edges are truly connected.



There are a lot of resources to be found. But I think if you’re relatively new. Take a couple of projects you want to draw. and post up questions about things you run into on this forum.

You’ll end up with folks showing you how to do things more efficiently, and effectively. . . and you’ll be drawing something you care about along the way.

It would be a good start to upload the model you’re working on right now.



Now I know some folks around here will read this, and wonder why in the heck does this clown edit his post 10 times.

I just want to say that the vast majority of those edits were me trying to push my preferred choice of words through this unfortunately overly family friendly forum.

We all have one, why can’t I say Ass when I want to?

The forum software has an automatic censor system that apparently either can’t be turned off or the administrators decided not to turn off. There have been a couple of amusing threads in which people explored the sometimes silly boundaries of this censor.

No worries. I’m old, too.

It’s hard to say exactly without seeing your model. It may be that you don’t need to be hiding and/or locking things.

Face orientation shouldn’t change randomly. Generally it is wise to maintain correct face orientation and correct reversed faces when they occur. Even if you don’t plan on rendering or 3D printing, it’s just a good idea. If you practice clean efficient modeling as you go, you’ll find the entire process easier and more enjoyable.

There is a setting in window>Model Info>Components for hiding the rest of the model when editing components/groups. Perhaps you have that enabled. It has its place although in my workflow I prefer not to hide the rest of the model because I frequently use what I’ve drawn as a reference for what I’m drawing.

In order to get a face to fill, no matter what its shape, all of its vertices and thus edges must lie on the same plane. If you are drawing a rectangle or other shape with the Line tool, it may be that you are drawing some edges slightly off plane. One thing you can do to check is to draw in lines to form triangles. By definition the vertices of a triangle will always lie on a plane.

As Jim said, there’s room for improvement but… The Intel HD Graphics cards are known to be less than stellar for OpenGL support. It’ll probably suffice for now but if you decide you need a better one, you’ll most likely need to change the entire machine.

Also, as Jim pointed out, the thing you may be seeing with Zoom is that the cursor location has a big impact on the speed of the zoom action. If the cursor is on a near part of the model zooming will be different than if it is on a distant part of the model or is over empty space. With practice it’ll become second nature to put the cursor on the thing you want to zoom in on. The same will apply to orbiting. the center of the orbit will be where the cursor is when you activate the tool. Do make it a habit to use the center mouse button/wheel for navigation. It’s much more efficient than using keyboard shortcuts or picking the tools off the toolbar.

That’s a great thing! Keep having a ball.

Thanks, guys. I’ve read and absorbed what you’ve written, and I appreciate your help !

(Yes, forum sensors are a bit silly, aren’t they. I’ve found I can space a word (s e x) and it will pass . . .)

Zoom: Yup, I was not placing the cursor on the geometry – must have been doing it correctly earlier, so didn’t have the problem. Didn’t know the same is true of Orbit . . .

Filling: I see now that using the rectangle tool rather than drawing lines is the way to go. I’ve caught several non-planar faces already. One of my problems on the model is canted rectangular planes. I’ll have to find a better way of making those.

I have a long “stick” that wouldn’t fill on one face; just now I tried extruding it with Push-pull, and bingo.

Colors: I found the face-reversal tool in Paintbucket. I was thinking of using the color contrast for aesthetic purposes; it’s good to know what the functions actually are !

Here are screen shots of my model, which is intended as a concept tool. I completed the facade so the client could show it as needed in the planning process (neighbors want input on these projects). The object is a three-level “batchelor pad” on an alley street here in San Francisco, replacing a ramshackle 20’ x 25’ garage.

Partially completed second level, with third-floor street wall selected to be a Group so I can remove or hide it for the time being, completing it later. One issue here: I want to make one or both side walls removable. I assume these should be Components, as they are identical (one is in place now). I wish I could draw them in situ and then separate them, but I guess I must construct them as independent objects. Can I pull construction lines from the building to aid in this ?

Here is the second level with more parts added – after I had made it a Group, hidden it a couple of times, and locked and unlocked it (for some reason).

And here’s the first floor, unhidden.

Here I’ve hidden the second floor, so I can work on the first. Is that the only way to do it ? Note that parts I added after the original second-floor Group was created are not hiding.

Here is the bench object (I was going to say component, but that word – like a half-dozen other common words – has a specific meaning, I’m learning !) that I was having trouble with. The back side (last image) shows where I wasn’t able to fill without leaving triangles. I’m redesigning this element (where’s the glossary ?) so will trash it anyway.