Logitech M705 Scroll wheel not working properly

zoom

#1

Use Sketchup Pro for a building project drawing and a LogiTec M705 mouse. The Zoom function is going absolutely crazy. Have seen others have same issues here but so far the solutions suggested has not worked. Earlier posts suggest this is a problem with the mouse driver from Logitec and it’s settings. If this is the case I would believe the zoom when scrolling function would not work consistently all across the board when opening different drawings but this is not the case. I can open several drawings made earlier and here the zoom when scrolling works perfectly fine ( without changing any settings in either drivers or SU ) It also works perfectly fine if starting a new drawing. Furthermore, the zoom when scrolling function worked perfectly fine on the drawing in question up til a certain point when things started to go all over the place - or nowhere at all when scrolling. Since I can imagine several users working with the Logitec M705 Scroll mouse in SU I wonder if someone have managed to find a permanent fix to this issue and would be able to post provide a fix for the problem?


#2

Could it be that you aren’t understanding that the cursor is the center of the zoom.
If you try to zoom on nothing, nothing appears to happen, if you zoom on something in the foreground it zooms faster than something in the back ground.


#3

Nope, that does not seem to be the case, the issue seems to be that the scroll function at some point simply lost it’s fine touch. You either stay light years away from the drawing or race right past it, - the Orbit function still works just fine but lining the zoom tool up and having a bit of fine control seems pretty much impossible, even when you do get down to the actual drawing all it takes is a click too far back or forward on the scroll and you fly back into outer space. It seems as if something is preventing SU in interpreting the input from the mouse properly and since it works just fine on other drawings it points towards something in the specific drawing that causes this behavior without being able to pinpoint exactly what.


#4

Without seeing the model, a gif or a screenshot it’s hard to diagnose.
It could be clipping…


#5

I can send you a link to the file via drop box if you would like to see if there is anything obvious I am missing. Not sure if SU can send PM, will check.


#6

Cannot send PM, will leave a link to the file here for a little while:

( Link deleted )


#7

This is nothing to do with your mouse.
Have you imported this from some other CAD program?


#8

No, built from scratch in SU. Have imported 1 3D person for scaling purposes and copied him several places but rest of drawing is mainly in 2D at this stage, 3D modeling will start after floor plan is finalized.


#9

Well I’m totally lost as to how you managed it.
You had text tags 9 km from the origin, and the whole model was inverted.
I have removed all the text and flipped the axes.
As I mentioned, this is nothing to do with your mouse.
Any other help I can give you will be later as I’m going to bed now.

Floorplan version 1 Gudvangen base right side up.skp (2.9 MB)


#10

Thanks a million for your help and advice, I will download and check. I may have ended up grapping some of the text tags by accident when the problem started and dragged them out backwards with me when scrolling and autosave may have happened as well. Will re-post here if problem continues.


#11

Problem was in the file itself - which I in hindsight could have identified by a more systematic approach during fault tracing. I opted to post on the forum after waisting 3 hours looking around for problems with my mouse driver, settings etc.

  1. Since I could navigate normally in other Sketchup files I made using the same mouse, it would be highly unlikely this would be a mouse software problem. If so, this should have been consistent across all files.
  2. Suggestion: If you encounter a similar problem, first check if the problem appears in more than just one file by starting a new file and checking if same problem also appears here. You may also try to connect a different mouse ( which I also did ) to see if same problem still exist using a different pointer/ scroll device, If it does, this could indicate problem is in the file, not in the scroll device.
  3. As Box pointed out, my file had Text tags scattered around in orbit far away from the center of the model, - these may have been saved after being highlighted by me and then auto save kicked in - check your model: - If you got Satellites ( items ) orbiting your model far away ( by mistake ), this may be the cause of confusion for your mouse/ scrolling device. When this happened to me I did a Google Search on " Sketchup zoom gone crazy " and it brought up various threads related to the Logitec M705 suggesting the problem was with mouse drivers. In my case this turned out not to be the case, file navigates normally now after I got rid of the items hovering around far away from the model.

Thanks Box for taking the time to care, I very much appreciate that!


#12

I am having same problem with my M705 from opening Sketchup 17. not sure why this would be, but super irritating. Have you found a solution? It is the software, not the mouse in my eyes as no other Sketchup does this with my mouse.


#13

Did you read the thread you posted your question to?
The result was that it was unrelated to the mouse.