Mouse zoom impossible


#1

don’t know what I did but I got the wrong topic on my last post.
My mouse zoom is out of control. I found another post on the same topic but no resolution.
SU works normally when I open it. At some point the mouse wheel zoom goes out of control. It is like it is sending 100 zoom steps per stop.
It does not happen in any other program. It is a logitech M705 and the control is set for 1 line per stop on the wheel. Since it operates properly up to some point, and does not do this on any other programs I am placing blame on SU. Somehow SU is seeing more commands than is being sent.

But what can I do to fix this??


#2

And you move your mouse cursor over the geometry before the zoom action?


#3

In other words, a cursor over empty 3D space is on a vector from the screen surface to infinity. Positioning the cursor over some geometry before zooming gives SU spacial reference.


#4

no, it does not matter where the mouse pointer is, any mouse zoom, either way, runs at 100 MPH. I cannot turn the wheel slow enough to get where I want.
The issue is intermittent, but once it starts I must close/reopen the file.


#5

Use a generic OS mouse driver rather than a custom driver.

-Gully


#6

The same thing happens with my Logitech M310 --using Logitech’s software. I have yet to revert to the OS’s native drivers, and I plan on it as per the recommendations I have read several times, but I found if I go into another program and use the scroll wheel, when I go back into Sketchup the problem’s corrected.


#7

How large is the areal extent of your model? If it is very large, relative to the size of the objects you are trying to zoom, that might cause issues. Could you post your model so we can see if there is something amiss in it?


#8

If you use a manufacturer mouse driver, try updating that driver.


#9

I have an HID compliant mouse and a Logitech hid compliant unifying mouse entry under Mice and other pointing devices. They are both up to date according to MS.


#10

Under mouse properties, do you have a tab labeled SetPoint Settings? SetPoint is the name of the Logitech control panel that comes with their driver. If you happen to be using the Logitech driver, check with Logitech for any update. Drivers can become corrupted.


#11

#12

I have this problem with the same mouse. The best investment I made (or had the company make) was a 3D mouse. It lets me control the zoom a LOT better than a the scroll wheel. I wish I would have had it years before…I had to have carpal tunnel surgery last year because I literally was scrolling too much, it hurt to scroll! I’d rest my wrist on ice packs when I worked.
I’d find the zoom issue happens when working small parts of large models (spatially, not necessarily file size) . Cutting and pasting a part into a clean file and working on it seemed to help also. Not always though, and a pain when you just want to make a quick small change and can’t zoom into it.


#13

I got tendonitis from scrolling too much a while back! I bought a vertical mouse for maybe ten dollars on Amazon, and I love it. Here’s a photo: http://ecx.images-amazon.com/images/I/41-3EAJKJoL.jpg
I really want to try a 3D mouse also, though. Looks so fun. A good mouse makes such a huge difference when modeling.