Mouse Wheel Ratchet Clicks

I’m wondering if anyone else is in this situation. I’m using SU Pro on a Mac Studio with a Microsoft Bluetooth Mouse 3600. Everything seems to be working fine. However, the centre-wheel on the mouse moves on a little ratchet like mechanism. As you move it, it goes click-click-click and things scroll or move as expected. Except in SketchUp. If I use the wheel to zoom in our out on something it LOOKS fairly smooth, but I think SU is treating every start and stop as if I’d stopped the mouse. The problem with that is if the mouse stops over an open space suddenly that becomes the pivot point and then the zoom goes zipping off into the background. The same thing happens when I zoom out. If the pointer happens to be over an open spot the model zooms out really fast. I hope that makes sense.
I’m wondering if anyone else has similar problems and/or what would be a good mouse to switch over to. I’m also using a3DConnexion 3D mouse which also behaves like a mouse.

Can’t speak to your exact issue but wondering have you set the mouse up on your system. You go to Systems Preferences > Mouse , if the computer recognizes the mouse it gives the ability to make various adjustments for how the mouse works. I will add that I’m running an ancient iMac and have never had to mess about with mouse settings. I’ve always used a “Logitech M325” mouse and never had any issues. Plus side it’s an inexpensive mouse.

It does matter where you point the cursor when you zoom. An interesting experiment is to move the cursor totally out of the SU drawing window when you do some things. In particular, with the 3D mouse, having the move tool selected often pulls SU to it’s knees trying to navigate, but moving the cursor out of the drawing window means it’s not hunting for inferences, I’m guessing, and it speeds up.

I use an old Logitech MX Master and the wheel can be set to “ratchet” or not in the Logitech Options.
Not sure a Microsoft mouse has the same option.

I think this is most likely the problem…
But this is intended behavour. If it wouldn’t work that way you would either zoom through walls to quickly or zoom painfully slow when you want to zoom to something further away…

1 Like

Yes it does seem to matter. Let’s say the model is a house. If you have the cursor over an external wall and start zooming in things go fine, until a window or door crosses the cursor during the zoom, then the pivot point changes to infinity and you zoom through the window extremely fast. I think SU sees the ratchet movement as you stopping the zoom, it determines the pointer is over and open space, and it moves accordingly the next ratchet stop. I hope that makes sense.

It’s not much of a problem when you’re working on a large object, but let’s say you’re working on something like a picket fence. If you’re at an odd angle to it and zoom in, sure enough the cursor is going to end up pointing at the space between the pickets and you’re going to quickly zoom through it to infinity.

I’ve watched many of the live SketchUp shows on Fridays and have noticed that Aaron doesn’t seem to have the problem when he’s moving around. I know he’s much more proficient than I am but I’ve been using a mouse and 3DConnexion mouse for quite a few years without much of a problem.

I appreciate everyone’s input. In the end it’s probably just the nature of the beast that I have to get used to.

Thanks again

It has nothing to do with the “ratchet movement” as you call it. With the “ratchteting” turned off on my Logitech MX Master it behaves exactly the same.
It seems Sketchup is constantly monitoring the cursor and where it is over to determine the zoom speed…

@TheOnlyAaron uses his Space Navigator to zoom in and out. The Space navigator doesn’t use the cursor to determine zoom speed. Instead it detects how far you push the puck forwards or backwards…