Zoom extents grabs "something" and is larger than necessary


#1

zoom extents grabs “something” I have used hidden geometry but nothing shows up. I have selected the empty space hoping to grab “something” and deleting it, but without success. When I use the section plane, it also grabs “something” and I can not resize the section plane to just the model. Any ideas how I can delete, get rid of this “something” ???

running sketchup pro 2017 on a Macbook pro 16GB memory 64bit machine


#2

Could you upload the SKP file so we can have a look to see what’s happening?


#3

Two Story House5.skp (851.6 KB)

sure,


#4

Select whatever you definitely want to keep then, ⌘X >> ⌘A >> >> ⇧ V [ cut, select all. delete, paste in place ]…

john


#5

Turn on all the layers. I think what you’re seeing is due to the elevations.

By the way, you aren’t using layers correctly in your model and that is likely to lead to problems. You should keep all edges and faces on Layer 0. And you should leave Layer 0 active at all times.


Why does SU not enforce drawing on layer 0?
#6

This is my first attempt to use sketchup, so there is a learning curve here. I used John’s suggestion and it worked to get rid of the “something” to zoom extents works very nicely, zooming up on only visible geometry. But the section plane still wants to grab everything even if that layer is turned off. Is that just how it works???

“You should keep all edges and faces on Layer 0. And you should leave Layer 0 active at all times.” If everything gets put (drawn) on Layer0, How does it get put on layers so geometry can be turned off???

I also have a problem with the doors where they are on two different layers, you can’t see them unless both Beam2 and Interior Walls is turn on. I have tried using entry info to place them on one layer, but they are still on two layers???


#7

Only groups and components get assigned to other layers, the edges and faces within the groups and components remain on Layer 0 at all times. Read the help files for information about layers in SketchUp.

That’s because you’re using layers incorrectly. See above.


#8

You probably have this solved by now, but just on the part about selecting an empty space: if you select by doing a drag from the left to the right, you have to have completely enclosed the item for it to select. If you drag from right to left, the item, and what it belongs to, will get selected.

If you still have the problem file you could try that, do a select with a top right to bottom left drag around the area, and see what gets selected.


#9

thanks Colin, that was very insightful. I was frustrated about the selection process. Sometimes I could select an object and other times I could not, other times I would only part of an object and the whole thing got selected. I will pay attention which way I select something to see the result. thanks for that tip.


#10

Okay DaveR, I have massively messed up, so how do I fix what I have???


#11

there was an edge of 63 m laying around on the Red Axe. This was placed on Layer0. Hidden geometry doesn’t show up on Layers which visibility is turned off. To avoid such issues you must always select the active layer to be Layer0. Groups and Components should be placed on Layers.
So, to repair the mess:

  • Set active layer to Layer0

  • Turn visibility on for all layers

  • Open a group for editing (be sure you are at the lowest level of group hierarchy ), select all entities and place them in Layer0 via the entity-window

  • Close group

  • Continue for all Groups/Components


#12

Probably the easiest way to fix the layer thing is to set the radio button back to Layer 0 and use ThomThom’s CleanUp3 which is available in the Extension Warehouse to return the geometry to Layer 0.

One-eyed Mike mentioned a line on Layer 0 laying on the red axis. I have it selected in this screen shot. Without it being selected it would be difficult to see.