Zero-distance guide point can't be interacted with in any way

guidepoints
guidepoint
tapemeasure

#1

As discussed here:

Please note that the problem has been confirmed by two other users; see the referenced thread, where one of them posted a screen capture to demonstrate it.

The problem is that a guide point that is created using the tapemeasure, but with a zero distance from the originating point, becomes some kind of “zombie”: It can’t be snapped to, not deleted, not selected, nothing. Not even “Select all” seems to include it. One user reported that it can be found using Ruby. One user reported that it worked fine first, but later the problem occurred every time he tried it.

Steps:

  1. Click an existing point, e.g. another guide point or an object node.
  2. Move mouse in a specific direction (negative blue axis in my case).
  3. Type the distance “0mm” and hit Enter.
  4. As expected a guide point appears at the location that was clicked in step 1.
  5. Removed the pre-existing originating point from step 1 by deleting that object.

I am not sure step 5 is required for the problem to occur, but it makes the problem easier to observe.


Zero-distance guide point can't be selected, snapped to, deleted