Tape Measure won't create guide points

guidelines
cpoints
guidepoints

#1

For a long time, I have been using the tape measure to create guide points by starting at a point (like a midpoint) and beginning to move along a line, then typing in a measurement (say 2’ 3.5") and hitting “enter”, which creates a little “x” on the line exactly 2’ 3.5" from the starting point. I use this feature constantly with great utility. Now, in the latest version (16.1.1449 64-bit) I will occasionally get into a situation where Sketchup will not infer my intent, and refuses to allow me to create a guide point even if I use the “ctrl” key to force it out of guide line mode. In fact, if I start in guide point mode, start my action, type in the length, then hit enter, it creates NOTHING (no guide point or line) and switches to guide line mode (the cursor changes to have the “+” beside it) and it is otherwise as if I have done nothing more than hit the ctrl key once (which I didn’t). I may be wrong, but it seems to start behaving like this after I have used “ctrl+z” at some point to undo something. This problem all but renders Sketchup useless for me, so any advice would be greatly appreciated since I have found no decent alternatives.


#2

If you have the Tape Measure tool active and hit Ctrl, even with Z for Undo, you will change the tool state to measure only. Just hit Ctrl again to enable the guidelines/points.

This will prevent the tool from making guidelines/points.

To get guidep points you muse start at an end point or intersection. Clicking on a midpoint of an edge will not get you a guide point. Instead you’ll get a guideline parallel to the edge. That particular behavior has always been like that. At least since V3.


#3

Dave, thank you SOOOOO much for your reply… The first part of your comment I already knew (or figured out while working with this problem)… but the second part… I did not realize that you could not start from a “midpoint” to start my action to create a guide point. In this particular project (a poker table) the fact that I have two “ends” of the table that are basically mirror images of each other makes using the midpoint of the edge of the table more likely and frequent. After reading your reply, I first created a guide point to mark the midpoint, then used that as a starting point for other guide points, which worked perfectly.
Thank you again for your quick and extremely useful reply. As simple as it may have been to you, you have solved a very frustrating problem for me, in just a few minutes. THANK YOU.


#4

I’m happy that helped.

Out of curiosity, what do you use that guide point located at the midpoint for? Since you can already inference off the midpoint, is it possible you don’t need a guide point there?


#5

I need to mark points for the cup-holder holes in the plywood surface. I generally just start by adding guide points so that I can save and come back later once I have purchased the cup-holders, so I know for sure what the diameter of the holes should be. It took me a bit of math to figure out exactly what the spacing should be to get them equally spaced around the table, so I wanted to go ahead and mark the spots while it was fresh in my head. That said, any advice is welcome.


#6

I see. It would be interesting to see your model. Perhaps I could offer some suggestions. If you don’t want to share the SKP file publicly, click on my name at the top of this post and then click Message. You can attach the SKP file in a private message, then.


#7

Let me get a little bit further along first. If I have the opportunity to get some feedback, I would like it to be on something far enough along that you can see where I’m going, and I can get some really helpful info. I will send you something probably later this evening. Thanks for the offer.


#8

That sounds fine.


#9

Dave,
I clicked on your name and there does not appear to be a “message” option of any kind. Is there another way I can send you the file?


#10

That’s strange. Did you look here:


#11

Here is what I see:


#12

From the “Welcome” message:

Why can’t I do certain things?
New users are somewhat limited for safety reasons. As you participate here, you’ll gain the trust of the community, become a full citizen, and those limitations will automatically be removed. At a high enough trust level, you’ll gain even more abilities to help us manage our community together.
We believe in civilized community behavior at all times.
Enjoy your stay!


#13

Haha… Ironically, I guess my previous message got me trusted enough, now I can send a message. On the way…


#14

So I see how this works, but in the attached model, I’m trying to create a guide point from A to B, and also from A to C I managed it once, using the inference of point at A and created a guidepoint at point B. Then I tried to replicate it to point C and couldn’t. So I deleted the A to B guidepoint to try create it again and I’m thinking it was a fluke first time. What might I be doing wrong? I need to create the guidepoints outside the groups, and so the only inference colour point I get is the purple ‘Endpoint in Group’ I know this is a simple matter (even for simple me), and I often just ignore this puzzle and do things a different way, but I’m sure it must be possible. It’s the principle of the thing!
uprights.skp (87.8 KB)

I’ve typed ‘pint’ instead of ‘point’ numerous times now. I think it’s telling me something.


#15

I’d be inclined to think that, too.

I had a look at your model and no problems creating guide points relative to other endpoints and guide points.

I’d like to set up a time we could look at this together so you can share your screen with me and I can see what you are doing. Like you, I expect it’s something simple but I’m not able to see it while looking at your model on my computer.


#16

You can only create guide points starting at a vertex or at another guide point.
Or when starting at intersections of:

  • edge x face
  • edge x guide
  • guide x guide
  • guide x face
  • edge x section plane
  • guide x section plane
  • and the one(s) I might have missed

Note that there needs to be a ----+ at the cursor tip to be able to create the guide or guidepoint.
Otherwise its just measuring distances.


#17

Thanks both for your time. No idea what I’m doing wrong still


#18

I should have added: you can’t end (second and final click) on one of the locations mentioned above.
So don’t second click on a vertex or guide point or intersection. That will create either a guide or measure a distance.


#19

So are you saying I can’t do what I am asking to do (apart from doing it a different way)?


#20

I didn’t see any point A, nor B, nor C in your model so I have no clue what it is you are trying to achieve creating guide points. But no doubt there’s a way out.
I just summed up the “restrictions” for creating guide points, (see above).
What is your goal?