Yet another Bug Splat upon startup

Hello,

I have recently installed Sketchup Pro 2020. Upon launching it, I get the [Welcome to Sketchup] window with the [Create New Model] tab. When trying to choose any, it crashes into a marvellous Bug Splat…

I have spent Around 8 hours trying to fix the issue. I upgraded .NET to the latest version available on the Microsoft website. I upgraded my Video Card Driver to the latest available on the NVIDIA website. In the NVIDIA control panel, I did change the settings to “High performances” and set the OpenGL thingy to “GeForce MX250”. None of this made a difference.

When I try to use the “repair” tool from the installer, it starts loading stuff, and after a bit, it prompts me with a “missing msi” dialog. When looking for answers on this issue, I ended up on a Sketchup Community thread where an employee provided a .msi file. I tried linking it in the dialog from the installer, but it brings even more errors, and there is no way I can finish the repair.

From the Bug Splat window, I have no way of clicking the “View Report Details” button. I’d like to see some logs telling me what’s wrong… Why does it have to be so complicated, for an issue apparently so frequent, according to Google search results ?

My laptop runs a 64-bits Windows 10. I have a GeForce MX250 graphics card. I have .NET v4.8. I’m runnning Sketchup Pro 2020.1.1. What else can I provide ?

Are you sending the Bug Splats with your e-mail address or name attached so someone could identify them as coming from you?

It appears you have installed the latest 20.1.229 version. It has several issues, the repair issue is one of them, another is a Layout issue. You can find several reports about this here on the forum. I also had stability issues with the very latest Sketchup (crashing).

For myself (as others I have been in contact with) the solution so far has been to reinstall the slightly older 20.0.373 version. Then all problems went away.

You might therefore attempt to install the mentioned 20.0.373 version as this is more stable. However, I cannot - of course - be certain that this will fix your specific issue. It might be worth a try…

2 Likes

Are you including your name and email in the BugSplats? If so, please send me a PM with your details and I’ll investigate further.

Hello,
I indeed had a newer version (20.1.235 in my case). Using an older version just did the trick ! I couldn’t find the version 20.0.373, but I managed to get my hands on the 20.0.363, which worked like a charm !
About sending the bug reports, I didn’t send any reports, but since it’s now solved, I guess it’s not a big deal anymore :slight_smile:

Thanks a lot for the quick responses !

Your bug splats could have been useful in tracking down the problem. Maybe for someone else since you decided to revert to an earlier version. Sending the bug splats gives the developers at least a chance to fix it if it’s something on their end. Typically Bug Splats on startup are actually related to graphics driver problems. Either way, it would have been helpful.

20.0.373 is also a Windows version.
image
I did send several bug splat reports before reverting to a previous version - just to get som work done.
As did several other Sketchup users I know of.

Yes, I see that 20.1.235 is now available.
image
However, as per your experiences, it appears that some errors (introduced in 20.1.229) are still present in the latest version.

So I think I will cling on to 20.0.373 for a bit longer…