Bug splat when I try to open sketchup pro 2021 trial

Hello,

I just downloaded the Sketchup pro trial 2021 and after it downloaded successfully, I tried to open it and every time I get a bug splat error. This is the same for the style builder and layout.

Does anyone have any ideas on how to fix ?

Many thanks,

Natasha

hello,
did you install sketchup by right-clicking on the installer and run as administrator ?
if no, please do. If it still doesn’t work, you can try updating your intel drivers https://downloadcenter.intel.com/ with their automatic tool, then restart

Hello,

Thank you for your reply - I have updated the drivers and also tried opening as an administrator and I unfortunately am still receiving a bug splat report. I have checked the requirements and I have 6GB worth of space so should be plenty of room for the program

When you say you tried opening as an administrator, you are talking about the installer, right ? not sketchup ?

Are you sure you don’t have any graphic hardware beside HD intel graphics ? go to your device manager and check under graphic cards (to quickly access device manager, type windows key + pause, and it will be on the left side of the opened window)

Yes I opened as admin from the install and no luck.
I have attached image of the device manager. I am on windows 8 which I think the 2021 version does not support? However, I have since tried to download the 2020 version and still no luck

this is the system info, on the left side, you should have a link to the device manager (you can also search for it in the windows menu)
it should look like this (but in english…) :

Seems to only be coming up with the Intel® HD Graphics 4000

indeed !
Well… 2021 version is not officially compatible with windows 8, but I run it under windows 7 without any trouble. Check if you have windows updates available
Can you try installing sketchup make 2017 instead, and see if the problem persists ?

Otherwise you can always use the free online version here : https://app.sketchup.com/

The version of SketchUp won’t be the reason that Device Manager only sees one GPU. If you think you have another GPU, something else is going wrong.

SketchUp 2021 does warn against Windows 7 and 8, but does seem to work ok. My guess (without knowing for sure) is that future versions of SketchUp may fail to open in Windows 7 or 8.

Hello Colin, I was the one asking if there was another GPU, thinking it might be the cause. Apparently not ! But I wanted to make sure, as I don’t find th reason…

Your question was a good idea, I was only adding that if the machine has two GPUs, and one isn’t showing up in device manager, it wouldn’t be SketchUp that caused that.

1 Like