X-ray opacity slider disabled under material transparency on Mac

On SketchUp 2020 for Mac, the x-ray opacity slider under material transparency in the Styles palette is disabled, and the faster/nicer pop-up menu is also enabled and disabled incorrectly. I feel like SketchUp 2020 has some control enabling/disabling issue in this palette…

When material transparency is checked, the opacity slider remains disabled when nicer is selected, and the opacity amount in the also-disabled number field sometimes displays “50” and sometimes displays “65”. Also, the faster/nicer pop-up menu is not enabled and disabled correctly when the material transparency checkbox is enabled and disabled… You can uncheck the material transparency checkbox and the pop-up menu remains enabled, but switching the style tab to edge and back to face will update it. I can also get the material transparency checkbox to be disabled and non-selectable after a bit of random button-clicking in the Styles palette. So something is very amiss.

Do you have an in model material selected when you are trying to adjust the slider?

Invoke the X-Ray Tool if you wish to adjust it’s transparency in Styles…

john

DaveR, it’s the Styles palette and not the Colors palette (on a Mac). The opacity for a color/material works fine.

Your original post was a bit confusing. Did you do what John suggested?

As a software developer myself, I was hoping that my post was clear enough, but also I run into reading users’ bug reports and scratching my head :slight_smile: To clarify, in the Mac 2020 version of SketchUp, the X-ray opacity slider under Material transparency is not enabling properly. It doesn’t matter whether you are in X-ray mode or not, the slider does not become enabled, for me. And the Faster/Nicer pop-up also misbehaves at times, not accurately enabling and disabling when the Material transparency checkbox above it is checked and unchecked.

My assumption is that either there is some event handling that changed in 2020 that is the cause of this, or there is something corrupt in my machine’s prefs files that is having an effect on this setting. I would like to know if anyone else is seeing this issue.

So fi you click on the X-ray button does the opacity slider become active. In your screen shot you have the Face Style set to Shaded with Textures but X-ray is not shown as enabled…

This is obviously on PC but it should be the same on Mac.
Screenshot - 4_6_2020 , 11_51_23 AM

Screenshot - 4_6_2020 , 11_50_46 AM

Nope. The slider is permanently disabled. This worked in 2019, and I just happened to want to use the “nicer” setting in a model, so I have only noticed it now in 2020 :confused:

Hmmm… @john_drivenupthewall or @slbaumgartner do either of you see this?

And to add clarifying details, the material transparency setting is working properly, the faster/nicer setting is also working correctly, and x-ray mode is working fine. It’s just that the opacity slider is permanently disabled, for me.

I’m about to temporarily rename my SketchUp 2020 folder in ~/Library/Application Support and see if I get different behavior when it rebuilds a new support folder from scratch. Will report back…

I’m seeing the same problem here on macOS 10.13.6 and SketchUp 2020.

Recreating a fresh new SketchUp 2020 folder in ~/Library/Application Support didn’t change the behavior… The slider still remains disabled.

Thanks McGordon for the confirmation that I’m not alone :slight_smile:

Yes, I see it too. I’ve tried a lot of combinations and none of them appear able to activate that slider. John may know something I don’t.

1 Like

While the troubleshooting is focused on this Mac Styles palette, the dev(s) should look at the enabling/disabling of the “Faster/Nicer” pop-up menu as well. If you uncheck the “Material transparency” checkbox, the “Faster/Nicer” pop-up menu does not immediately disable. However, if you click the button for Edge settings and then click the button for Face again, the “Faster/Nicer” pop-up menu is correctly disabled. The same thing happens when you check the “Material transparency” checkbox then switch to Edge and back to Face to enable the “Faster/Nicer” pop-up menu.

The faster nicer not disabling when turning off Material Transparency, and the slider not appearing, is only on Mac.

EDIT: this IS broken in SU v2020 for me as well…

john

Thanks John. I’d add for the dev(s) that even the palette control behavior in 2019 is a little wonky… The X-ray opacity slider is enabled by the “Nicer” setting in the quality pop-up menu above (according to the SketchUp docs) but that quality pop-up is not modal to the current X-ray mode, so it’s odd that the X-ray slider is enabled only when in X-ray mode. I can understand an argument for this behavior, but then I would argue that the pop-up menu should also adhere to the same modal behavior and only be enabled when in X-ray mode. My added 2 cents :slight_smile:

Not to hijack the thread, but the Level of Detail slider and Stroke window for sketchy edges are also missing from the Style edit window on Mac starting in 2020. While we’re fixing things…

So I opened an older 2019 file today that already had “Transparency quality” set to “Nicer,” and the X-ray opacity slider is active. The text labels above and below the slider are dimmed which isn’t correct, but the slider responds to clicks and the text field next to it is active and can have a value entered directly. Extra info for troubleshooting.