Wrong LenY value


Why does the LenY value does not show the correct value?

Thanks in advance.

My component options are also not visible/shown in the dialog.

I opened up the Ruby console, and the problems where solved.

Sorry I thought is was fixed, but it is not.

You can see the ruler and LenY do not match.

The first “child” (nested) component is an Auto Cut-&-Glue compo. That may be realigning the Origin and thus, throwing off the Axes Definitions.

fix the lost references and repost

I removed the glue, but still no success. I removed the lost references.

@pcmoor If you can check for me, thanks in advance!

Test.skp (245.8 KB)

For some reasons all my newly created dynamic components have the same problems.

I set the height 100cm and the result is 39.37007874015748 cm

I hope somebody can figure this out with me, so I can continue creating my models.

Post your component. Your formula converts your height value to inches. I don’t know if the “cm” at the end of your post was added by you.
What are your settings for the A01_height parameter? I would set it to be Centimeters and to display the end user’s units.
Is the “Display units format” box checked in your model’s Modei Info>Units dialog? An old. old, still standing bug causes non-inch length calculations to fail if it is not checked.

First is was set to text, if I set it to cm it will show correct in the attributes.

But the component options are not shown.

Alumunium wand.skp (14.4 KB)

Restarting Sketchup seems to resolve the not showing option problem

I have some custom parameters which were set as text. Setting them correctly to cm solved the problem that the results was shown in inches.

Sketchup seems a little buggy. Sometimes the options are not visible and sketchup has to be restarted.

The same goes with placing a dynamic component not snapping to the right point on axis.

Restarting sketchup also solves this.