Dynamic components length issue

Got an issue with the length field in Component Attributes not matching the length in Component Options

Any ideas why this isn’t matching?

That looks like an issue with units. As 204 x 2.54 = 518.16
They are matching, just not in the correct unit.

I would guess that the “Display units format” box in your Window menu>Model Info>Units window is unchecked. Dynamic components have a long standing bug (since they were introduced more than ten years ago) where the internal component units revert to inches if the units suffixes are set to not display.

No its checked

But how would that set it self that way without setting it as a formula…….was following the ‘welcome to Dynamic Components Part 2- Skill builder’ tutorial on youtube

While you are following that tutorial, you might find it easier to use the same units as the Aaron does. That’ll at least get you through working with DCs. Then add in working with your desired units.

Well technically, “=LenZ” is already a formula even if it’s a simple one. Sometimes there’s bugs in DC with units. When it just won’t work, I change it to text with something like this:

=CONCATENATE(ROUND(LenZ/2.54, 2), " cm")

That’s compensating for a size that’s getting multiplied by 2.54 when it shouldn’t be.

Edit: There’s other settings that you’ve not shown us, such as the details you see when you click the icon at the right of the field. Can you share the SketchUp file with us?

Right now, I can’t get it not to work, but I’ve had units problems lots of times with DC.

Edit 2:
I’ve manage to break it by turning “Display Units Off” as @Anssi said. Turning it back on again doesn’t fix it. Now this works, no need to divide by 2.54, it’s just reading LenZ as cm:

=CONCATENATE(ROUND(LenZ, 2), " cm")

Test 1.skp (163.8 KB)

I haven’t played with this in years but saving the file and restarting SketchUp might fix it.

No tried that it opens the same

I changed the formula for Length:

Changed the details for the Length formula to “Display in: Text”
Length_details

Component Options now:

File:

Test 1-2_gm.skp (167.9 KB)

I Did two versions …the first following the tutorial in inches (as the video showed) that one worked fine however we work in metric so need to get it to work properly in mm which seems not to be giving the result needed if I follow the same tutorial

Cheers ….yes that looks like the fix…just annoyed that for some reason I cant get the same result from inches to metric with the original formula … Oh well :confounded:

Yeah well, welcome to Dynamic Components!

In mm:

=CONCATENATE((LenZ*10), " mm")
1 Like

I could not understand why it was a problem, then realized in your original upload you did not set the attribute to centimeters, rather you allowed the default

, which is grey, text always assumes inches, the default for this "great’ american product

That helped …thanks