Dynamic Components - Attributes just dont work!

Trying to get up to speed on Sketchup Pro

as our studio is switching over when we come out of furlough… second tiime of trying to get my head around Dynamic components…However each time i try i dont get the same results as the training videos.

Ive signed up the the Linkedin site and working through the Scott Onstott Tut on Dynamic Components and at the attributes part… XYZ position …On the Video he adds = to the front of each box and the box goes from grey to black…when I do the same I get a completely different result… This is the second video this has happened on (gave up with the first ) .

Any ideas whats going on ?

for metric
delete “cm” use just the number

=0
not
=0 cm

Fantastic…that worked :slight_smile:

And remember that whatever the metric template you may be working it SU in general, and DCs in particular ALWAYS regard ‘bare’ numbers or text as inches. Changing the DC units to cm changes only the display of lengths to the user AFAIK. And unless you explicitly set the Option/Attribute input to expect cm, it will treat text as inches. So you have to be careful, and convert from inches to cm and back using the exact ratio 2.54 cm = 1 inch, internally.

It can get very confusing, and the first few times I tried to make a DC that would work for metric units, I tripped over this issue constantly. If i tried to make a new one now, I’d have to look back at an old one to work out how to do it.

For your tutorials I’d suggest setting your model units to Decimal inches and a couple of decimal places. It will at least prevent that issue tripping you up.

Cheers will do…considering the majority of the world works in metric you would have figured the developers would have addressed this issue by now…

DCs have had very little if any development since they were first introduced - around SU 7 or 8 I think.

See t his former thread - it might help if you later want to develop metric DCs.

I see Philip Moore replying - he knows far more about DCs than I do.

1 Like

as John stated, text is always valued as inches, You can work in metric however, just beware of text!

With any custom attribute, even though you may have cm displayed, you must choose centimetres in the details and a metric or model units in the display if you want to include this in a report.

Capture
Capture2
Capture3

There are two functions that return inches,
FaceArea
Current
for facearea, you have to times the result 2.54*2.54
for Current, times the result by 2.54

So you can understand why some work in inches, but I still favor Metric

see this,

2 Likes

I feel your pain as I have experienced it often enough myself. Every now and then I have a go at mastering DCs and am in process of doing so now with time on my hands.

As @john_mcclenahan has pointed out, DCs have never really evolved since their first outing when announced to great fanfare. Lots of quirky things about them would probably have been ironed out by now if developers had retained an interest in them. If you have watched any of @TheOnlyAaron’s 8 part tutorial on them, you will see that even he, in a prepared for video, keeps forgetting to press enter after entering a formula. And so so I. It’s very frustrating.

Like you (and most of the planet), I work in metric but you probably have to make some allowances for something developed in the US. You do get used to it, but do occasionally get tripped up. Sometimes, without you realizing it, the little ruler slyly reverts to inches. You can spend some time wondering why things aren’t working the way you expect until you clock that you need to revert to cm.

Another headache is the fact that it uses cm and cannot accept mm, the unit that architects (and engineers?) use most. If you are inputting user defined optional sizes into Component attributes, you have to keep remembering that what you think of as 500mm will be interpreted by the system as half a metre and so you enter 500mm in one box and 50cm in the other. Not too hard but have to wonder why input is made so hard.

DCs can be mastered as there are some people who have managed spectacular things with them. But the learning curve is steep.

And be VERY aware that if you try almost anywhere in SU in a metric unit model, to enter any dimension, and input anything in US Customary/Imperial Foot, Inch and Fractional units you get reproducibly crazy results - see SU doesn't recognise fractional inches (e.g., 1/2") as an imperial measurement when units are mm