Component Options Denominator Problem

Can someone explain what is going on with dimension lines for this component?.

The sizes are called out in the Component Options as millimeters.

In the Model Info Dialog Box:
Length Units are set to DECIMAL:MILLIMETERS
Precision is set to to 0mm:Display Units Format

When I size the component to be 650mm X 927mm, for example, the dimension lines call out 256mm x 365mm.

The only correlation I can see between these numbers is maybe a decimal conversion(minus the decimal).
25.6 inches rounds to 650 mm
36.5 inches rounds to 927mm

Is this a bug or do I need to flip a switch somewhere?box.skp (36.7 KB)

I don’t know much about dynamic components, but I see that inside your one is FaceFrame, and it’s at the size you’re seeing on the outside. Is FaceFrame a SketchUp thing?

Not a DC expert but I think they always use inches internally?

It’s a bit confused. It’s safest to work internally only in inches, but displayed values to the user can be any unit.

There are several threads on the forum about this - I ran into difficulties myself and posted about it. The replies help clarify what is going on.

So am I accurate in assuming I cannot reliably build dynamic components using millimeters as my basic unit of measurement?

You can use cm as your basic unit, but as you realize, inches is the default, so the value of a text will be inches, therefore other than selecting cm in the named part of the attribute dialog, you must also select centimeters in the value input verification, not just except the grey default: text,

There are two functions that return inches, that is CURRENT and FACEAREA, where you need to convert to cm, 2.54, and 2.54*2.54 respectivity

1 Like

Thanks Phillip.
I rebuilt the dialog box using Centimeters as the input unit & that solved the problem.

On to my next problem!

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.