Units for dynamic component attributes


#1

The only options appear to be inch or cm, I know I can type in mm & it works but isn’t there a global setting for units so that mm can be set without having to key in mm ?


#2

Change the units for the model and the Dynamic Components units will follow.
Window/Model Info/Units.


#3

Unfortunately not. And when you attempt to use mm in formulas, they fail. About all you can do is use your own custom attributes and base the built-in attributes on your custom ones.

LenXmm: =700
LenX: =LenXmm/10

In this case you would remember to always use LenXmm instead of LenX directly in all references.


#4

I had already set model units to mm, I checked & they still are mm, yet in attributes they default to cm, not a major problem but would be good if applying units would carry into all functions


#5

Ok , yep I see they don’t change in all respects.
But in the options window they do.



#6

The general idea is to use either inches or cm in the parameters and formulas. Then, to achieve what Box shows in his screenshots, you set the parameters that are visible to the user to show “End user model units”.

Dynamic components have a bug where, if the user has unchecked the “Display units format” box from the Window>Model Info>Units dialog, all dimension units displayed revert to inches.

Anssi


#7

This behaviour is still there. Maybe it is intentional. Anyone ?


#8

Yes, it is. And it’s irritating, as the standard for dimensioning in millimeters or centimeters is to suppress the dimension format.