Wrong dimensions

Ok guys, I have a problem. I select rectangle tool, like I always did, draw a rectangle of some dimensions, then i enter desired dimensions. Until now, that worked perfect, but, when I installed SketchUp on mz fresh installed win 10, the values are wrong. It looks like this:
step1- select tool
step2- draw rectangle
step3- enter dimensions
step4- use tape measure tool and check
conclusion: the dimensions are wrong. tape measure is correct, because the rectangle I draw also looks wrong.
hope someone will be able to tell me what went wrong.
thanks :slight_smile:

What language is your keyboard set for? Did you enter the dimensions separated by a comma or a semi colon? Try the other one and see what you get.

1 Like

Ok, changed language to ENG, numbers are separated by comma, like always, and same thing happened now again. I tried different template settings. I use metric units, exactly, millimeters. Using Sketchup for furniture design.

To what is Precision set in Model Info>Units?

When you installed SketchUp, did you install by right clicking on the EXE file and choosing Run as administrator?

What dimensions do you expect?
What dimensions do you end up with?

1 Like

What does mz mean?

You say the rectangle looks wrong.
Can the parallel and perspective view have something to do?

Share a screenshot and attach your .skp to take a look at.

As @Thorleyian said, what dimensions you enter and which ones are the result or the operation?

precision is set to 0,0mm, I think I installed it as administrator…

If you only think you installed using Run as administrator, maybe youshould do it again to make sure…

MZ is a typing error, my bad.
well, however you look at the drawn object, the size is just wrong. For example, I tried to draw a rectangle 1300,300 and end up with something like 1301,786… or so, it is not the same each time.
I use metric units, millimeters to be exact.

Well, will try…
The interesting thing is that I installed it on my old computer running win7 and worked like a charm… Now, it just goes wrong…

Just out of curiosity, you aren’t clicking in the Measurements Box before typing your dimensions, are you?

Nope, never had to do that, just draw a rectangle and type numbers. like I always did. and I made some fantastic projects with success…

Just checking. Clicking in the measurements box is not done but there have been users who have done it and gotten similar results to yours.

Im not really a computer magic man, just use drawing programs to create furniture, Im trying to make a screenshot to show you what happens…

that should have been 300mm wide

You can try what Dave said:

Right click over the installer.exe and choose run as administrator, then select repair option.

Attach a.skp file to your post and tell us what dimension they should be.

wrong dimensions.skp (13.3 KB)
ok, and the dimensions I have typed were 1300,300

The result is not always the same, right?

Because it’s length is 1300,3 and your units precision is set to 0,1
Try changing the units precision to 0,001 and draw a rectangle 1300,356 and see if the lenght result is 1300,356
Did you try with typing 1300;300 instead of 1300,300?
I mean I’m afraid your second dimension is getting as part of the first one. 1300,300 = 1300,3

1 Like

OK, you now have to come to Bosnia and I should buy you a beer. this separating thing worked like a charm. thanks man!

Cool, good to know it.