Sizing doesn't work like I thought it would


#1

Hi all, new here. I am trying to build a house with 20’ x 40 ’ dimensions, and when I input those dimensions, the rectangle shows up as long and narrow. Not nearly what it really looks like. So either I’m doing it wrong or looking at it wrong. Anyone have any ideas?

Thanks!
Glen


#2

@glen_knox76

Try separating your measurements with a comma, rather than an ‘x’. That should get you the measurements you’re after.

Welcome to the forums!

~Drew


#3

Hi Glen,

It’s not clear if you’re referring to use of the Scale tool or the Rectangle tool.
Thus, I’ll treat you to a double feature.
Feel free to ask followup questions.



#4

None of this helps. Years ago I used earlier versions, but now I type in the dimensions separated by a comma and it snaps to a size - just the wrong one. Are there known issues with international settings in the OS? It’s sadly pretty useless if something this basic doesn’t work right off the bat. Any help much appreciated.


#5

considering that it works for 99.9% of all users, there may be an issue with your particular setup or technique…

can you supply more details of the steps that appear to be failing…

john


#6

Thanks for the quick response. I’m clicking once, releasing, moving the cursor a ways and then simply typing the dimensions. When I hit return the rectangle snaps, but not to the desired size. I don’t see a place to configure presentation of numbers on Sketchup, so I’m assuming it’s the core system. Most other applications and software allow it to be configured locally, but I’m guessing here it takes the system default. I’ll post back if I find a solution!


#7

Where are you? What localization of SketchUp are you using? What are the units set to in SketchUp? Look in Window>Model Info>Units.


#8

you can set the model units to whatever you use, or you can change them on the fly by adding the identifier…

i.e 200mm,10" or 2cm,3m ect…

john


#9

Depending on your local Windows settings, roughly:

  • if you use a point as the decimal symbol, you use the comma as the separator character
  • if you use a comma (,) as the decimal symbol, as in most of Europe, the separator is a semicolon (;)

Anssi


#10

Thanks Anssi, John, and DaveR!

Anssi has it right, my system requires the use of , and ; as noted. In other software I’ve adjusted in the software, because sometimes I use that standard. Even in Europe it varies by country! I really appreciate the quick responses here in the forum and from Sketchup. I will give myself a little more time before becoming frustrated now that I know a) it’s a great product, and b) there’s such a good support community behind it.