Good day, I am working on a Dell laptop and having trouble with my dimensions.

I also installed a sketchup trial on another laptop and everything seems to be working fine. But on my laptop its not. I checked the Model Info settings as well, everything is fine, and I check the preferences as well, everything is fine.

For example when I want to draw a square (5000mm, 5000mm) it gives me a rectangle and not a square. The dimensions and meausurements just seems of.
I don’t know if it is a setting on my laptop or on sketchup self.

Please assist ASAP, as I have a big project to work on and the due date to be soon.

Thank you.

First thing I would do is drag out a rectangle and look at the separtor between the dimension numbers. Is it a comma or is it a semicolon? Use the same separator.

Don’t put a space between the comma and the second dimensio.

I don’t know what version of windows you’re using but on windows 11 you can change the separators between period, comma and semicolon. In case you are used to one format and your pc is using another one.

I have windows 10. Where do I change the separators?

It is a comma, with no space.
On the other laptop it worked perfectly, but not on mine?

On system preferences/Time and Region/language and region/configuration of language, then a new window will pop up, on the upper left corner click on the format tab, there you can change the separator. It may be different on windows 10, I use mainly Mac and got my PC with windows 11 a few months ago.

So it’s a comma on both machines? Then you don’t need to do what @francisquitof is talking about.

Are you moving the cursor into the Measurements window and clicking before you start to type? If so, don’t. There’s never any need to click in the Measurements window.