Problem with manual dimensions

Hello,

I’m new to sketchup, so I tried to use the sketchup web for personal. It is not cheap but it is giving me problems with the manual dimension input. Please help.

What’s the problem that you face with manual dimensions input?

After I pull and placed the rectangle in place, when I type the numbers and press enter, it doesn’t give the right measurement of the dimensions that I wanted. I use feet (’) or (") separated by a comma. For example, if I want 4’,4’…it ends up with a different measurement like 2’3" by 6’4"…or any number except the 4’ by 4’. I keep making new model and don’t save the error ones but it still keep doing the same thing. Also, if I undo it, when I put new rectangles, the numbers don’t change the dimensions anymore after I press enter. And when I use the push and pull moving up, when I type the number and press enter, it doesn’t change or do anything to the dimension. It only worked everytime I change to a new model but gives wrong dimensions anyway, so, basically, the manual dimension is not working. :frowning:. Sorry for the very long post.

I had the same problem when I first started, but I managed to fix it.
Instead of holding the mouse whilst typing the values in, try clicking the mouse, then type in your the values you want. The same applies to Push/Pull, click then type. I tend to find this issue more problematic when using imperial measurements as typing the " (double ) requires the use of stretching fingers from “shift” to (apostrophe).
I’m sure you know this, but don’t click the values box when you type or else nothing happens.

When you drag out the rectangle, make sure you click and release the left mouse button to set the first point, then move the mouse in the general direction toward the diagonally opposite corner. Look at the separator between the two dimensions in the Measurements window. Is it a comma or a semi colon. If your localization uses a comma for decimal separators, you’ll use a semi colon in the measurements window between the dimensions. Also make sure you aren’t clicking in the Measurements window before typing the dimensions. This is a common new user “oops”. There’s never a reason to click in the Measurements window.

FWIW, if you are using feet and inches, there’s no need to type the " for inches as they are understood by SketchUp.

2 Likes

@DaveR’s response is better than mine. See his instead.

I’m curious how something that is free is also not cheap.

2 Likes

I bought the sketch up Shop which is $119/year for Model personal projects.

Thank you. I will try it. Try and try until you succeed :slightly_smiling_face:

Thank you DaveR. I will try that for sure.

1 Like

Well, you might find even for personal projects that the additional tools are worth the cost. Especially the Solid Tools.

Which version are you actually using now, then? Your first post and profile indicate you are using the free version but now you say you have Shop. If you are using Shop, please correct your profile.

Okay. On the plans and pricing, for personal… the free, shop, and pro are included in the choices. Sorry, I’m a newbie, don’t know much…yet. But, I just upgraded to sketchup pro. I’m new also to DIY woodworking, so, cross my finger, I just hope this investment is worth it.

It would help if we could work out what you have paid for and what you actually have. It makes a difference how questions are answered due to differences in how they work. Also it’s not uncommon for people to pay for pro and struggle with only the web version.

Uhm, okay. It looks like I have so much to understand than just my problem with manual dimensions. Thanks for the tip.

If you show us a screen shot of the SketchUp screen you are working with, we can probably sort out which version you are using. As Box wrote, in order for us to help you it’s important for us to know what version you really are using so correct information in your profile is important.

melissa_grace0605 I can see that you bought Shop, then upgraded to Pro. If you didn’t already do it, you can download the desktop application from this link:

Windows SketchUp 2021 installer

After you have installed SketchUp, start working on a new document and see if the entering dimensions works like it should, and then reply with any remaining questions, along with screenshots if that will help explain the problem.

Mind you, there is no significant difference from web to desktop pro for your original question.

I am trying to study the Pro version as of this moment. I will try your advices too. Will let you know how it went. Thanks.

So happy!!! Worked like a charm. It might not be because it’s the pro, it might be because of how I held the mouse but I finally got the 4’ by 4’. But, regardless, headache is gone. I even got the push and pull working too :grinning_face_with_smiling_eyes:. I’m making something like magic. Thank you for the advices guys. You all rock!