Typing Dimension on free version not working

Hello community,

I am new at sketch up. How can I type dimension in sketch up free version. I have used everything that I saw online to try to fix it. When I type the dimension nothing happens. Also, when I am dragging a shape I dont understand the measurement that it appears. I am attaching a screenshot.

Thank you for your help!

Looks like your shape is 1500453 feet and 3 and 13/16 inches wide, or about 285 miles. Is that the scale you were intending to work at? It might be difficult to operate on something that big

To enter a dimension or dimensions start a tool, say the rectangle tool. Click and release once to start the rectangle and begin dragging out the rectangle in the direction you want by moving the mouse. Then without doing anything else let go of the mouse and type 10’,5’ and hit return. You will have a ten by five foot rectangle. Do not try to click into the box, just type once an action is started and you will see the dimensions appearing in the box.

hahahaha, wow! I just want to do a rectangle 8’ long by 14 9/16 wide. I have tried to do it with “,” , “;”., decimals, no decimals, etc. When I enter the dimensions nothing happens.

Thank you for your help!

Start a new file with the scale figure and draw a proportional sized rectangle.
Hit ‘Shift Z’ to see everything in the model (Zoom extents)

It Worked, thank you very much! I wonder why it gave me such a huge dimension the first time I tried.

Thank you!!!

1 Like