Manual input of dimensions in 'Length' box not working

Unable to manually enter dimensions of lines and rectangles into the dimensions box on my.sketchup web version. The dimensions appear in the box when drawing but even though I can highlight the text I cannot edit it. This makes accurate drawing nigh on impossible

You shouldn’t need to highlight the text or go anywhere near the box. You just enter the lengths when you are part way through drawing, So to draw a 2ft square you would start dragging a rectangle then type 24,24 followed by Enter.

1 Like

Thanks for that, it was as easy as I thought would be.

How about when using the tape measure. I want an exact measurement that mouse does not allow me to get or it takes a long time. How can I put in exact measurement?

Click and release to set the start point for the Tape Measure, drag out in the desired direction, let go of the mouse and type the distance.

It’s exactly the same in my.SketchUp as it is in the desktop version.

Just tried it and it works the same.Select the start point and the
direction of travel and enter the length on the keyboard, it magically
appears in the length box.

There should never be a reason to click in the Measurements box. Just start the tool and type the appropriate value.

2 Likes

Thanks, that worked

Thanks for finding this one, guys- keyboard focus is a little fiddly in SketchUp, looks like you found a hole we need to fix.

john
.

Is it possible change the unit of measurement for the model?
I note that I can write the unit m or cm after digit the length ; for example (1m or 1 cm)
but it’s possible have the decimal system as default

@dipcorner, see: Mysketchup : switch to metric

I am having the same issues when trying to enter dimensions in the dimension box. When I start to enter dimensions the box immediately reverts back to what the current dimensions are. This seems to happen while making squares and lines. In using my.SketchUp on a Windows 7 Professional using Chrome.

Are you clicking in the Measurements box before starting to type? If so, don’t. Just let go of the mouse and type the number.

Hi DaveR, thanks for the quick reply. That’s exactly what I’m doing, is letting go of the mouse and typing my dimensions. Just like I’ve done in other versions of SketchUp I’ve used. Plus should I be inputting inches such as 36" or can I input 3’ or does it matter? Thank you.

And it isn’t working?

To what do you have Units set? If it’s inches, you can just type 36. Or you can type 3’

As soon as I start typing my dimensions the numbers start to show up but then it immediately returns to the current drawn dimensions of the function I’m doing. I’m finding this is happening when I’m drawing lines and squares. I’m using inches.

Is your mouse moving at all while you’re typing? Do you ever see the cursor moving by itself?

No the mouse is not moving

Hi, I’m having the same issue in my.Sketchup as stpierre.charles.

When I try to enter a value into the Measurements box, the box will refresh while I’m typing. My values disappear and revert back to the current dimensions. I’ve tried changing up the Format and Precision settings in the Model Info screen and changing how I enter in the Measurement values. No luck.

It appears that the cursor is constantly “refreshing.” I’m drawing a rectangle on the surface of another object (which is grouped). The “On Face in Group” message pops up over my cursor. With the rectangle roughly drawn I let go of the mouse (I haven’t clicked or done anything else) as if to enter in a Measurement value. The pop-up message is disappearing and reappearing every second or so, and this coincides with the Measurements box refreshing.

To be clear, my mouse is not moving nor does the my.Sketchup cursor move.

This is still a problem on chromebooks. If I start to set a guideline with control and drag in the proper direction, once I start to enter numbers no numbers appear in the measurement box. " and ’ will appear. but no numbers. I confirmed it works on chrome in OSX exactly the way I am attempting to use it in chrome on ChromeOS.

It makes sketchup basically useless.